summaryrefslogtreecommitdiff
path: root/korean/hlatexfonts-ocf/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>1999-09-03 16:07:54 +0000
committerSADA Kenji <sada@FreeBSD.org>1999-09-03 16:07:54 +0000
commit6f11a72612e884fbb749e9639eaec3196bc8d619 (patch)
treecf0f70e0ba5155cb80287ead9b41ce66dfc826a0 /korean/hlatexfonts-ocf/Makefile
parentupgrade to 1.3.9 (diff)
2 set of Korean PS fonts, for use of Netscape or others.
PR: ports/13495 Submitted by: CHOI Junho <cjh@kr.FreeBSD.org>
Diffstat (limited to 'korean/hlatexfonts-ocf/Makefile')
-rw-r--r--korean/hlatexfonts-ocf/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/korean/hlatexfonts-ocf/Makefile b/korean/hlatexfonts-ocf/Makefile
new file mode 100644
index 000000000000..d23d7da19a1c
--- /dev/null
+++ b/korean/hlatexfonts-ocf/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: HLaTeX OCF fonts collection
+# Version required: none
+# Date created: 30 Jun 1999
+# Whom: CHOI Junho <cjh@kr.freebsd.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= hlatexfonts-ocf
+PKGNAME= ko-hlatexfonts-ocf-1.0
+CATEGORIES= korean print
+MASTER_SITES= ftp://ftp.kr.freebsd.org/pub/users/cjh/gs-ko/
+DISTFILES= HLaTeX-Myoungjo-OCF-PS.tar.gz HLaTeX-Gothic-OCF-PS.tar.gz
+
+MAINTAINER= cjh@kr.freebsd.org
+
+BUILD_DEPENDS= $(LOCALBASE)/share/ghostscript/fonts/Fontmap:${PORTSDIR}/print/gsfonts
+
+NO_BUILD= YES
+
+do-configure:
+.for FAMILY in Myoungjo Gothic
+ ${SED} -e 's@(@(HLaTeX-${FAMILY}\/@' \
+ < ${WRKDIR}/HLaTeX-${FAMILY}/Fontmap.HLaTeX-${FAMILY} \
+ > ${WRKDIR}/HLaTeX-${FAMILY}/Fontmap.${FAMILY}
+ ${RM} ${WRKDIR}/HLaTeX-${FAMILY}/Fontmap.HLaTeX-${FAMILY}
+.endfor
+
+do-install:
+.for FAMILY in Myoungjo Gothic
+ ${MKDIR} ${PREFIX}/share/ghostscript/fonts/HLaTeX-${FAMILY}
+.endfor
+ ${CP} ${PREFIX}/share/ghostscript/fonts/Fontmap \
+ ${PREFIX}/share/ghostscript/fonts/HLaTeX-Myoungjo/Fontmap.before
+.for FAMILY in Myoungjo Gothic
+ ${INSTALL_DATA} ${WRKDIR}/HLaTeX-${FAMILY}/* \
+ ${PREFIX}/share/ghostscript/fonts/HLaTeX-${FAMILY}/
+ ${CAT} ${WRKDIR}/HLaTeX-${FAMILY}/Fontmap.${FAMILY} \
+ >> ${PREFIX}/share/ghostscript/fonts/Fontmap
+.endfor
+
+.include <bsd.port.mk>