summaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-10-18 01:44:16 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-10-18 01:44:16 +0000
commit41f67973868680f4e84c23edd6859bf6f47b0cd0 (patch)
tree575cc8970aacbb6acf8385d4685029032a05b570 /java
parent- Chase g-wrap downgrade (diff)
Disable two more self-tests, which may hang in rare circumstance.
According to SleepyCat/Oracle, these will be fixed in the next release. Provide two explicit download sites for those, whose FETCH_CMD is set to NOT follow redirects (as is the default). Oracle uses such redirects to facilitate downloads from the server closer to the downloader, but the scheme breaks, when the redirects are not followed. Approved by: portmgr (erwin)
Diffstat (limited to 'java')
-rw-r--r--java/berkeley-db/Makefile4
-rw-r--r--java/berkeley-db/files/patch-test-failure25
2 files changed, 27 insertions, 2 deletions
diff --git a/java/berkeley-db/Makefile b/java/berkeley-db/Makefile
index 1bb3b2f39d5d..2623c4391c29 100644
--- a/java/berkeley-db/Makefile
+++ b/java/berkeley-db/Makefile
@@ -8,7 +8,9 @@
PORTNAME= je
PORTVERSION= 3.1.0
CATEGORIES= java databases
-MASTER_SITES= http://download.oracle.com/berkeley-db/
+MASTER_SITES= http://download.oracle.com/berkeley-db/ \
+ http://download-east.oracle.com/berkeley-db/ \
+ http://download-west.oracle.com/berkeley-db/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Berkeley DB Java Edition
diff --git a/java/berkeley-db/files/patch-test-failure b/java/berkeley-db/files/patch-test-failure
index 29913a6862d7..468c02c1edd7 100644
--- a/java/berkeley-db/files/patch-test-failure
+++ b/java/berkeley-db/files/patch-test-failure
@@ -1,6 +1,13 @@
-This is a temporary work-around for a spurious test failure. See the discussion at
+This are temporary work-arounds for spurious test failures. See the discussions at
http://forums.oracle.com/forums/thread.jspa?threadID=431242
+and
+ http://forums.oracle.com/forums/thread.jspa?threadID=431549
+
+The last one appears somewhat scary, but SleepyCat/Oracle's support assures me, the problem
+can be ignored as it has to do with the test framework and not the software itself.
+
+ -mi
--- test/com/sleepycat/je/recovery/CheckpointActivationTest.java Tue Sep 12 15:17:22 2006
+++ test/com/sleepycat/je/recovery/CheckpointActivationTest.java Fri Oct 6 23:42:55 2006
@@ -11,3 +18,19 @@ This is a temporary work-around for a spurious test failure. See the discussion
+ public void meowLogSizeBasedCheckpoints()
throws Exception {
+--- test/com/sleepycat/je/test/DeferredWriteTest.java Tue Sep 12 15:17:24 2006
++++ test/com/sleepycat/je/test/DeferredWriteTest.java Tue Oct 10 17:22:34 2006
+@@ -524,5 +524,5 @@
+ }
+
+- public void testCleaning5000()
++ public void meowCleaning5000()
+ throws Throwable {
+
+@@ -530,5 +530,5 @@
+ }
+
+- public void testCleaning2000()
++ public void meowCleaning2000()
+ throws Throwable {
+