summaryrefslogtreecommitdiff
path: root/japanese/ptex-pkfonts300/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-27 01:15:39 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-27 01:15:39 +0000
commitb01b7ee4d06293b223554bb4b1821981e8172a12 (patch)
treeb0a20a397eb8c3390e4bf08702d9b1c9b78d834f /japanese/ptex-pkfonts300/Makefile
parentUpdate to version 2.0. (diff)
Adding ptex-pkfonts* ports.
English PK fonts, for ghostscript5, xdvik, dvipsk, and so on. PR: 15650 Submitted by: Kentaro Inagaki <inagaki@tg.rim.or.jp>
Diffstat (limited to 'japanese/ptex-pkfonts300/Makefile')
-rw-r--r--japanese/ptex-pkfonts300/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/japanese/ptex-pkfonts300/Makefile b/japanese/ptex-pkfonts300/Makefile
new file mode 100644
index 000000000000..2318a1b2b6ef
--- /dev/null
+++ b/japanese/ptex-pkfonts300/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: ptex-pkfonts
+# Version required: ?
+# Date created: 24 Dec 1999
+# Whom: Kentaro Inagaki <inagaki@tg.rim.or.jp>
+#
+# $FreeBSD$
+#
+
+DISTNAME= ptex-pkfonts
+PKGNAME?= ja-ptex-pkfonts${RESOLUTION}-1.0
+CATEGORIES= japanese print
+DISTFILES= #null
+
+MAINTAINER= inagaki@tg.rim.or.jp
+
+RUN_DEPENDS= ${LOCALBASE}/lib/fonts/pk${RESOLUTION}:${PORTSDIR}/print/pkfonts${RESOLUTION}
+
+.include <bsd.port.pre.mk>
+
+NO_BUILD= yes
+PKGREQ= ${WRKDIR}/REQ
+
+# ******************
+# USEPK_MODE:
+# Mode name of Metafont to give to print/pkfonts* is set.
+# It is care-and-attention to the other program how MetaFont wants to
+# be executed that do not use modeless. Kpathsea always searches
+# modeless because even if you specify any kind of mode.
+# MAKETEX_MODE:
+# It is mode name of default at executing MetaFont. The default is ljfour.
+# This needs not to be changed. It can be changed with an option or resource.
+# ******************
+USEPK_MODE?= preview
+MAKETEX_MODE?= ${USEPK_MODE}
+RESOLUTION?= 300
+
+.BEGIN:
+.if defined(RESOLUTION) && \
+ ${RESOLUTION} != 118 && ${RESOLUTION} != 240 && \
+ ${RESOLUTION} != 300 && ${RESOLUTION} != 360 && \
+ ${RESOLUTION} != 400 && ${RESOLUTION} != 600
+ @${ECHO} "Error: invalid value for RESOLUTION: \"${RESOLUTION}\""
+ @${ECHO} "Possible values are: 118, 240, 300, 360, 400 and 600."
+ @${FALSE}
+.endif
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${SED} -e 's,%%RESOLUTION%%,${RESOLUTION},g' \
+ -e 's,%%USEPK_MODE%%,${USEPK_MODE},g' \
+ < ${FILESDIR}/REQ.tmpl > ${WRKDIR}/REQ; \
+
+do-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${WRKDIR}/REQ ${PKGNAME} INSTALL
+
+.include <bsd.port.post.mk>