summaryrefslogtreecommitdiff
path: root/japanese/p5-Text-ChaSen/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-02 07:00:32 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-02 07:00:32 +0000
commit6bcd1e4d5ffe2108239222a50bb211af3740f5ec (patch)
treebd1f22ef98765cfbaae0656b64e48b2b78287160 /japanese/p5-Text-ChaSen/Makefile
parentUse PERL_CONFIGURE. (diff)
Add ja-p5-Text-ChaSen, the ChaSen library module for Perl5, separated
from japanese/chasen.
Diffstat (limited to 'japanese/p5-Text-ChaSen/Makefile')
-rw-r--r--japanese/p5-Text-ChaSen/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/japanese/p5-Text-ChaSen/Makefile b/japanese/p5-Text-ChaSen/Makefile
new file mode 100644
index 000000000000..2e63c3361255
--- /dev/null
+++ b/japanese/p5-Text-ChaSen/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Text-ChaSen
+# Date created: 2 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-ChaSen
+PORTVERSION= 0.20
+CATEGORIES= japanese perl5
+MASTER_SITES= ftp://ftp.aist-nara.ac.jp/pub/lab/nlp/tools/chasen/
+DISTNAME= chasen-sys${CHASEN_VERSION}-ipadic2.1
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= chasen.0:${PORTSDIR}/japanese/chasen
+
+MD5_FILE= ${.CURDIR}/../chasen/distinfo
+
+CHASEN_VERSION= 2.02
+
+WRKSRC= ${WRKDIR}/chasen-${CHASEN_VERSION}/perl
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= PREFIX="${PREFIX}"
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Text::ChaSen.3
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/chasen/ja/README.perl
+.endif
+
+.include <bsd.port.post.mk>