summaryrefslogtreecommitdiff
path: root/japanese/ming
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /japanese/ming
parent- Allow for larger database UIDs (diff)
- update png to 1.5.10
Diffstat (limited to 'japanese/ming')
-rw-r--r--japanese/ming/Makefile4
-rw-r--r--japanese/ming/files/patch-util_png2dbl.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/japanese/ming/Makefile b/japanese/ming/Makefile
index d591baff108c..859dead19e44 100644
--- a/japanese/ming/Makefile
+++ b/japanese/ming/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ming
PORTVERSION= 0.1.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese graphics
MASTER_SITES= http://dist.bsdlab.org/
#MASTER_SITES= http://blue.ribbon.to/~harpy/ming/jaming/
@@ -16,7 +16,7 @@ DISTNAME= jaming-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= LGPL'ed Flash 4/5 movie output library with Japanese languages support
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
gif.5:${PORTSDIR}/graphics/giflib
CONFLICTS= ming-*
diff --git a/japanese/ming/files/patch-util_png2dbl.c b/japanese/ming/files/patch-util_png2dbl.c
new file mode 100644
index 000000000000..8782dda505ba
--- /dev/null
+++ b/japanese/ming/files/patch-util_png2dbl.c
@@ -0,0 +1,11 @@
+--- ../util/png2dbl.c.orig 2002-06-24 14:21:54.000000000 +0200
++++ ../util/png2dbl.c 2012-05-06 06:30:46.000000000 +0200
+@@ -80,7 +80,7 @@
+ error("Couldn't create end_info\n");
+ }
+
+- if(setjmp(png_ptr->jmpbuf)) {
++ if(setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ fclose(fp);
+ error("Mystery error (longjmp called)\n");