summaryrefslogtreecommitdiff
path: root/japanese/ming/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2014-06-14 08:38:25 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2014-06-14 08:38:25 +0000
commit10ff1c87b74d2c4ba869cc0ceb00a962a51c5f28 (patch)
tree6e8a177fc6ea7f6bbf3860c8539d368670529bd1 /japanese/ming/Makefile
parent- Remove easy_install dependency (diff)
- Stagify.
Diffstat (limited to 'japanese/ming/Makefile')
-rw-r--r--japanese/ming/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/japanese/ming/Makefile b/japanese/ming/Makefile
index ed7419383d2c..cdd230811df6 100644
--- a/japanese/ming/Makefile
+++ b/japanese/ming/Makefile
@@ -37,7 +37,6 @@ DOCS= CHANGES \
DOCS_UTIL= README \
TODO
-NO_STAGE= yes
post-extract:
${SED} -e 's:"\.\./\.\./ming\.h":<ming.h>:g' \
${WRKSRC}/ming.h > ${WRKSRC}/mingpp.h
@@ -69,19 +68,19 @@ post-build:
${CC} ${CFLAGS} -L${PREFIX}/lib -o swftophp swftophp.o blocktypes.o decompile.o read.o -lm
pre-install:
- ${MKDIR} ${PREFIX}/include/ming/blocks
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/ming/blocks
post-install:
.for f in ${UTILS}
- ${INSTALL_PROGRAM} ${WRKSRC}/../util/${f} ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/../util/${f} ${STAGEDIR}${PREFIX}/bin/
.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/ming/utils
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/ming/utils
.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${STAGEDIR}${PREFIX}/share/doc/ming/
.endfor
.for f in ${DOCS_UTIL}
- ${INSTALL_DATA} ${WRKSRC}/../util/${f} ${PREFIX}/share/doc/ming/utils/
+ ${INSTALL_DATA} ${WRKSRC}/../util/${f} ${STAGEDIR}${PREFIX}/share/doc/ming/utils/
.endfor
.endif