summaryrefslogtreecommitdiff
path: root/japanese/balsa/Makefile
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-13 09:34:41 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-13 09:34:41 +0000
commit8083c74dfed91ab1c264c22f4b8214b369839501 (patch)
tree4e83127a26101bc968d60228617a2e0d9eecf1ba /japanese/balsa/Makefile
parentPut pixmaps and sounds into share/gnome. (diff)
Fix my breakage. Install files in the right places, and use regex style
patching.
Diffstat (limited to 'japanese/balsa/Makefile')
-rw-r--r--japanese/balsa/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/japanese/balsa/Makefile b/japanese/balsa/Makefile
index 4db82a09e2d7..4af2f4593a0c 100644
--- a/japanese/balsa/Makefile
+++ b/japanese/balsa/Makefile
@@ -28,6 +28,14 @@ CONFIGURE_ENV= CPPFLAGS='-I${LOCALBASE}/include' \
LIBS='-L${LOCALBASE}/lib'
MAN1= balsa.1
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(gnomedatadir\)/gnome|\$\(gnomedatadir\)|g'
+
pre-configure:
${RM} ${WRKSRC}/config.cache ${WRKSRC}/libmutt/config.cache