summaryrefslogtreecommitdiff
path: root/irc/xchat-gnome/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 20:30:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-18 20:30:17 +0000
commit852053d6da1a50aad61ec5993fa9edb021c236dd (patch)
treef2cfbe221f024e60d5a6192725cbe0c2ad3a0e26 /irc/xchat-gnome/Makefile
parentUpdate to 0.9. (diff)
* Add optional Tcl support
* Convert from pkg-comment to COMMENT PR: 48438 Submitted by: Koop Mast <einekoai@chello.nl>
Diffstat (limited to 'irc/xchat-gnome/Makefile')
-rw-r--r--irc/xchat-gnome/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index ce18750b4151..0d2bcf156659 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -13,6 +13,7 @@ MASTER_SITES= http://xchat.org/files/source/2.0/ \
DISTNAME= xchat-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+COMMENT= An X11 IRC client using the GTK+ 2 toolkit
LIB_DEPENDS= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
@@ -48,8 +49,21 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB= PYTHON="@comment "
.endif
+.if defined(WITH_TCL)
+LIB_DEPENDS= tcl83.1:${PORTSDIR}/lang/tcl83
+CONFIGURE_ARGS+= --enable-tcl=${LOCALBASE}/lib/tcl8.3
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ -I${LOCALBASE}/include/tcl8.3" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} \
+ -L${LOCALBASE}/lib/tcl8.3"
+PLIST_SUB= TCL=""
+.else
+CONFIGURE_ARGS+= --enable-tcl=no
+PLIST_SUB= TCL="@comment "
+.endif
+
pre-everything::
-.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS)
+.if !defined(WITH_PYTHON) || !defined(WITH_SOCKS) || !defined(WITH_TCL)
@${ECHO_MSG} "You may specify the following on the command line:"
@${ECHO_MSG} ""
.endif
@@ -59,6 +73,9 @@ pre-everything::
.if !defined(WITH_SOCKS)
@${ECHO_MSG} "WITH_SOCKS=yes for SOCKS5 proxy support"
.endif
+.if !defined(WITH_TCL)
+ @${ECHO_MSG} "WITH_TCL=yes for tcl support"
+.endif
post-patch:
@${REINPLACE_CMD} \