summaryrefslogtreecommitdiff
path: root/irc/ircd-hybrid/files/patch-help-Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-01-29 18:21:06 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-01-29 18:21:06 +0000
commit56921ad5ba57f5f43e1eac7f64b260007eaadd32 (patch)
tree8f76a6916af9fed03461ac9961c703673a7b812b /irc/ircd-hybrid/files/patch-help-Makefile
parent1. Update 1.0.3 --> 1.3-rc7 (diff)
Rename patch files.
Port is still broken though. Submitted by: maintainer
Diffstat (limited to 'irc/ircd-hybrid/files/patch-help-Makefile')
-rw-r--r--irc/ircd-hybrid/files/patch-help-Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/irc/ircd-hybrid/files/patch-help-Makefile b/irc/ircd-hybrid/files/patch-help-Makefile
new file mode 100644
index 000000000000..f139d552d817
--- /dev/null
+++ b/irc/ircd-hybrid/files/patch-help-Makefile
@@ -0,0 +1,30 @@
+--- help/Makefile.in.orig Sat Feb 2 09:01:13 2002
++++ help/Makefile.in Tue Jan 6 02:08:07 2004
+@@ -8,8 +8,8 @@
+
+ prefix= @prefix@
+ exec_prefix= @execprefix@
+-uhelpdir= ${prefix}/help/users
+-ohelpdir= ${prefix}/help/opers
++uhelpdir= @uhelpdir@
++ohelpdir= @ohelpdir@
+
+ SYMLINKS= topic accept cjoin cmode admin names links away whowas \
+ version kick who invite quit join list nick oper part \
+@@ -63,12 +63,10 @@
+ install:
+ @echo installing help files...
+ -@if test ! -d $(prefix)/help; then \
+- echo "mkdir $(prefix)/help"; \
+- mkdir $(prefix)/help; \
+- echo "mkdir $(prefix)/help/users"; \
+- mkdir $(prefix)/help/users; \
+- echo "mkdir $(prefix)/help/opers"; \
+- mkdir $(prefix)/help/opers; \
++ echo "mkdir $(uhelpdir)"; \
++ mkdir -p $(uhelpdir); \
++ echo "mkdir $(ohelpdir)"; \
++ mkdir -p $(ohelpdir); \
+ fi
+ @for help in opers/*; do \
+ if [ -f $$help ]; then \