summaryrefslogtreecommitdiff
path: root/irc/icbirc/files/patch-icbirc.c
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2007-08-27 20:14:33 +0000
committerHiroki Sato <hrs@FreeBSD.org>2007-08-27 20:14:33 +0000
commit3bcf2e5850392304aed8e038112b71320f08037d (patch)
treec5279c951d1cc37a8ab70a9489b2e2800f9fddb5 /irc/icbirc/files/patch-icbirc.c
parentUse += to set LIB_DEPENDS and CONFIGURE_ARGS after bsd.port.pre.mk. (diff)
Update to 1.8.
Diffstat (limited to 'irc/icbirc/files/patch-icbirc.c')
-rw-r--r--irc/icbirc/files/patch-icbirc.c19
1 files changed, 5 insertions, 14 deletions
diff --git a/irc/icbirc/files/patch-icbirc.c b/irc/icbirc/files/patch-icbirc.c
index 2e4a9d19882c..72dac2faf679 100644
--- a/irc/icbirc/files/patch-icbirc.c
+++ b/irc/icbirc/files/patch-icbirc.c
@@ -1,22 +1,13 @@
-
-$FreeBSD$
-
---- icbirc.c.orig Wed Aug 20 23:55:59 2003
-+++ icbirc.c Sat Feb 14 23:09:01 2004
-@@ -318,12 +318,12 @@
- done:
- if (server_fd >= 0)
- close(server_fd);
-- printf("(%u seconds, %lu:%lu bytes)\n",
-- time(NULL) - t, bytes_out, bytes_in);
-+ printf("(%lu seconds, %lu:%lu bytes)\n",
-+ (long)time(NULL) - t, bytes_out, bytes_in);
+--- icbirc.c.orig Fri Nov 19 06:14:28 2004
++++ icbirc.c Tue Aug 28 05:12:05 2007
+@@ -322,8 +322,8 @@
+ (unsigned long)(time(NULL) - t), bytes_out, bytes_in);
if (terminate_client)
irc_send_notice(client_fd, "Closing connection "
- "(%u seconds, %lu:%lu bytes)",
- time(NULL) - t, bytes_out, bytes_in);
+ "(%lu seconds, %lu:%lu bytes)",
-+ (long)time(NULL) - t, bytes_out, bytes_in);
++ (unsigned long)(time(NULL) - t), bytes_out, bytes_in);
}
int