summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-12-24 12:35:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-12-24 12:35:11 +0000
commite691f03ea1f0de3fff66b71717676920b99f5881 (patch)
tree21a7c68707a066372c240204dc9284efb98e1347 /graphics
parentProperly support png 1.5 (diff)
Update to 2.5.9 which supports png 1.5
Remove bad and dirty png 1.5 patches
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gif2png/Makefile11
-rw-r--r--graphics/gif2png/distinfo4
-rw-r--r--graphics/gif2png/files/patch-gif2png.h11
3 files changed, 7 insertions, 19 deletions
diff --git a/graphics/gif2png/Makefile b/graphics/gif2png/Makefile
index b8c52328efea..3410008c4585 100644
--- a/graphics/gif2png/Makefile
+++ b/graphics/gif2png/Makefile
@@ -2,24 +2,23 @@
# $FreeBSD$
PORTNAME= gif2png
-PORTVERSION= 2.5.4
-PORTREVISION= 1
+PORTVERSION= 2.5.9
CATEGORIES= graphics
MASTER_SITES= http://www.catb.org/~esr/gif2png/
MAINTAINER= saper@saper.info
COMMENT= Converts GIF images to a PNG format
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
USES= python:run
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
PLIST_FILES= bin/${PORTNAME} bin/web2png \
man/man1/gif2png.1.gz \
man/man1/web2png.1.gz
-CPPFLAGS+= `libpng-config --I_opts`
-LDFLAGS+= `libpng-config --L_opts`
-
.include <bsd.port.mk>
diff --git a/graphics/gif2png/distinfo b/graphics/gif2png/distinfo
index e73cfad58110..93d5d09c5385 100644
--- a/graphics/gif2png/distinfo
+++ b/graphics/gif2png/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gif2png-2.5.4.tar.gz) = 0d78eb568198b568f7c1f535b9ec74fc6546864de11f57924c8e8db510423fef
-SIZE (gif2png-2.5.4.tar.gz) = 125731
+SHA256 (gif2png-2.5.9.tar.gz) = c8406b7c0c08f504952a1719e04f2366ee44c888c0edfac3a63fea2ab05b64c7
+SIZE (gif2png-2.5.9.tar.gz) = 137750
diff --git a/graphics/gif2png/files/patch-gif2png.h b/graphics/gif2png/files/patch-gif2png.h
deleted file mode 100644
index bcb02608a70b..000000000000
--- a/graphics/gif2png/files/patch-gif2png.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- gif2png.h.orig 2010-10-20 00:11:28.000000000 +0200
-+++ gif2png.h 2012-04-25 06:50:10.000000000 +0200
-@@ -2,6 +2,8 @@
-
- /* get png type definitions */
- #include "png.h"
-+#include "pngpriv.h"
-+#include "zlib.h"
-
- #define GIFterminator ';'
- #define GIFextension '!'