summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-06-28 13:02:47 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-06-28 13:02:47 +0000
commit6cf635af4a9920caea87d75f0c7552c3796fc84d (patch)
treee60ce09047527fdf53e87f775f14212156ed2fdd /graphics
parent- Support CFLAGS/PREFIX/LOCALBASE properly (diff)
- MAKE_FLAGS -> MAKE_ARGS
- Support CC/PREFIX/LOCALBASE properly - Add WWW: line into pkg/DESCR - Change MASTERSITE PR: 19342 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/dc20ctrl/Makefile5
-rw-r--r--graphics/dc20ctrl/files/patch-aa56
-rw-r--r--graphics/dc20ctrl/pkg-descr2
3 files changed, 58 insertions, 5 deletions
diff --git a/graphics/dc20ctrl/Makefile b/graphics/dc20ctrl/Makefile
index 7c923945b814..5f3c975beb85 100644
--- a/graphics/dc20ctrl/Makefile
+++ b/graphics/dc20ctrl/Makefile
@@ -8,15 +8,14 @@
PORTNAME= dc20ctrl
PORTVERSION= 0.4
CATEGORIES= graphics
-MASTER_SITES= http://aguirre.dsi.unifi.it/~paterno/binaries/
+MASTER_SITES= http://www.paternostro.org/~ugo/binaries/
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
png.3:${PORTSDIR}/graphics/png
-MAKE_FLAGS= -DUSE_JPEG -DUSE_TIFF -DUSE_PNG
+MAKE_ARGS= -DUSE_JPEG -DUSE_TIFF -DUSE_PNG
MAN1= dc20ctrl.1
-MANCOMPRESSED= yes
.include <bsd.port.mk>
diff --git a/graphics/dc20ctrl/files/patch-aa b/graphics/dc20ctrl/files/patch-aa
index 998adde0439e..040719482e72 100644
--- a/graphics/dc20ctrl/files/patch-aa
+++ b/graphics/dc20ctrl/files/patch-aa
@@ -1,5 +1,23 @@
---- Makefile.orig Mon Dec 21 21:09:06 1998
-+++ Makefile Mon Dec 21 21:09:19 1998
+--- Makefile.orig Wed Feb 18 19:30:56 1998
++++ Makefile Wed Jun 14 19:38:36 2000
+@@ -50,7 +50,7 @@
+ #
+ # How to install the package.
+ #
+-INSTALL=/usr/bin/install
++INSTALL?=/usr/bin/install
+ #
+ # Under FreeBSD we need to make it SGID to dialer, that is the serial port
+ # owner.
+@@ -60,7 +60,7 @@
+ #
+ # Where to install it.
+ #
+-ROOTDIR=/usr/local
++ROOTDIR=${PREFIX}
+ BINDIR=${ROOTDIR}/bin
+ MANDIR=${ROOTDIR}/man
+
@@ -79,7 +79,7 @@
#
# Used only if you make the project with USE_TIFF defined.
@@ -9,3 +27,37 @@
#
# Used only if you make the project with USE_PNG defined.
+@@ -91,8 +91,8 @@
+ # make the project with at least one between USE_JPEG, USE_TIFF and USE_PNG
+ # defined.
+ #
+-EXTRA_LIBS_PATH=-L/usr/local/lib
+-EXTRA_INCLUDES_PATH=-I/usr/local/include
++EXTRA_LIBS_PATH=-L${LOCALBASE}/lib
++EXTRA_INCLUDES_PATH=-I${LOCALBASE}/include
+
+ #
+ # Do not change anything below this line
+@@ -151,11 +151,10 @@
+ install: install.bin install.man
+
+ install.bin: $(PROJECT)
+- ${INSTALL} -c -g ${INSTALL_GROUP} -m ${INSTALL_MODE} ${PROJECT} ${BINDIR}
++ ${INSTALL} -c -o ${BINOWN} -g ${INSTALL_GROUP} -m ${INSTALL_MODE} ${PROJECT} ${BINDIR}
+
+ install.man:
+- ${INSTALL} -c ${PROJECT}.man ${MANDIR}/man1/${PROJECT}.1
+- gzip --best ${MANDIR}/man1/${PROJECT}.1
++ ${INSTALL} -c -o ${MANOWN} -g ${MANGRP} -m ${MANMODE} ${PROJECT}.man ${MANDIR}/man1/${PROJECT}.1
+
+ man: ${PROJECT}.1
+
+@@ -163,7 +162,7 @@
+ nroff -man ${PROJECT}.man >${PROJECT}.1
+
+ $(PROJECT): $(OBJ)
+- cc -o $@ $(OBJ) $(LFLAGS) $(LIBS)
++ ${CC} -o $@ $(OBJ) $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f $(OBJ) $(PROJECT) core $(PROJECT).core *.bak a.out .depend $(PROJECT)-${VERSION}.${REVISION}.tar.gz
diff --git a/graphics/dc20ctrl/pkg-descr b/graphics/dc20ctrl/pkg-descr
index 54da20a5f05e..e8d8606bfd56 100644
--- a/graphics/dc20ctrl/pkg-descr
+++ b/graphics/dc20ctrl/pkg-descr
@@ -4,3 +4,5 @@ the current state, taking a photo, downloading the thumbnails and/or the
pictures (in raw, pgm or ppm format, and eventually others: it depends on
compilation-time options), erasing the camera memory and changing its
resolution.
+
+WWW: http://www.paternostro.org/~ugo/English/dc20.html