summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2010-04-01 05:16:19 +0000
committerMark Linimon <linimon@FreeBSD.org>2010-04-01 05:16:19 +0000
commit686a04b74abcca3ca33bbecfc6929632e092e84a (patch)
tree3b8958b1bb3cc35feca131ed85cc953e08b14c9d /graphics
parent- fix build for png-1.4.1 (diff)
Mark various ports as broken or ignore on powerpc.
While here, remove remnants of alpha.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/goom/Makefile8
-rw-r--r--graphics/libvisual/Makefile2
2 files changed, 9 insertions, 1 deletions
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index d6f50edf05e7..b068e051dcd3 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -38,4 +38,10 @@ pre-everything::
@${ECHO} ""
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/libvisual/Makefile b/graphics/libvisual/Makefile
index 5c6972941e69..dec30095b890 100644
--- a/graphics/libvisual/Makefile
+++ b/graphics/libvisual/Makefile
@@ -27,6 +27,8 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
CFLAGS+= -mmmx
+.elif ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
.endif
post-patch: