summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-07 02:56:19 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-07 02:56:19 +0000
commit4c97fac781480b9e55094c6ca6fde0a5b2fa7bc8 (patch)
tree09bf1b0ba0412ce3204e2e0fa33dc5cd25e92407 /graphics
parent- Fix build with gcc-4.2 (diff)
Replace all INSTALL_DATA/INSTALL_SCRIPT and INSTALL_PROGRAM/STRIP=
hacks to install kernel loadable modules correctly on amd64 platforms with the new INSTALL_KLD command. All PORTREVISIONS have been bumped to show when the new version of installing became available.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kix-kmod/Makefile3
-rw-r--r--graphics/plasma-kmod/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/graphics/kix-kmod/Makefile b/graphics/kix-kmod/Makefile
index 204ff04419a5..b011ca1e4372 100644
--- a/graphics/kix-kmod/Makefile
+++ b/graphics/kix-kmod/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kix
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= graphics kld
MASTER_SITES= http://www.witchspace.com/files/
PKGNAMESUFFIX= -kmod
@@ -22,7 +23,7 @@ MAKE_ENV+= WERROR=
PLIST_FILES= lib/kix_saver.ko
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/kix_saver.ko ${PREFIX}/lib
+ ${INSTALL_KLD} ${WRKSRC}/kix_saver.ko ${PREFIX}/lib
post-install:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
index 27376d58a460..c41ae58608d8 100644
--- a/graphics/plasma-kmod/Makefile
+++ b/graphics/plasma-kmod/Makefile
@@ -7,6 +7,7 @@
PORTNAME= plasma
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= graphics kld
MASTER_SITES= SF/futurebsd
PKGNAMESUFFIX= -kmod
@@ -20,7 +21,7 @@ IGNORE= requires kernel source (/usr/src/sys) to build
PLIST_FILES= lib/plasma_saver.ko
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/plasma_saver.ko ${PREFIX}/lib
+ ${INSTALL_KLD} ${WRKSRC}/plasma_saver.ko ${PREFIX}/lib
post-install:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}