summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-12-23 07:57:52 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-12-23 07:57:52 +0000
commit1f8fc830f1bf5e84b573eba02eebc9b4cde4252f (patch)
tree795a05f5a465f695b223da74eb7d055567aa0fd8 /graphics
parentUpgrade to 1.8.0. (diff)
Make sure our CPPFLAGS and LDFLAGS get placed at the end of the compiler
arguments so the compiler finds the openjpeg 2.1 headers before the old 1.5 header. Which are installed in ${LOCALBASE}/include/openjpeg-2.1 and ${LOCALBASE}/include respectively. This fixes the build when the MODULES option is turned off, and both openjpeg ports are installed. PR: 195442 Submitted by: mail@ozzmosis.com
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 90ca5301495a..f9b139f9a97c 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -46,8 +46,8 @@ CONFIGURE_ARGS= --without-dps \
--without-lcms
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -isystem${LOCALBASE}/include
+LDFLAGS+= -Wl,-Y${LOCALBASE}/lib
SAMPLE_FILES= coder.xml colors.xml delegates.xml log.xml magic.xml mime.xml \
policy.xml quantization-table.xml thresholds.xml type-dejavu.xml \