summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-12 15:29:37 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-12 15:29:37 +0000
commitcdb8256f1be073ee580443f055cea42dfa4f0a8a (patch)
tree88f5fc59ca92cb0cc696d418e8dff349c265467f /graphics
parentnet/isc-dhcp41-server: Fix build with LDAP support (diff)
Fix problems with missing libs when the linker enforces explicit linking
(ports that are dependencies of other ports) net-p2p/transmission-cli: add USES=libtool and remove PTHREAD_LIBS sysutils/deltup: simplify patch by using MAKE_ARGS x11-fm/rox-filer: convert to USES=shared-mime-info x11-wm/emerald: remove PTHREAD_LIBS PR: 192062
Diffstat (limited to '')
-rw-r--r--graphics/autopano-sift-c/Makefile3
-rw-r--r--graphics/tif22pnm/Makefile2
2 files changed, 3 insertions, 2 deletions
diff --git a/graphics/autopano-sift-c/Makefile b/graphics/autopano-sift-c/Makefile
index 477822c4641c..4dd9085c2bdd 100644
--- a/graphics/autopano-sift-c/Makefile
+++ b/graphics/autopano-sift-c/Makefile
@@ -27,7 +27,8 @@ PORTDOCS= *
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's|share/man|man|' -e '/set(all_libs/s/$$/ m/' \
+ ${WRKSRC}/CMakeLists.txt
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/tif22pnm/Makefile b/graphics/tif22pnm/Makefile
index c832e2da041b..15f6638ddb0d 100644
--- a/graphics/tif22pnm/Makefile
+++ b/graphics/tif22pnm/Makefile
@@ -32,7 +32,7 @@ do-build:
&& ${CC} ${CFLAGS} -DNDEBUG -I${LOCALBASE}/include \
${TIF22PNM_SRCS} -o tif22pnm -L${LOCALBASE}/lib -ltiff \
&& ${CC} ${CFLAGS} -DNDEBUG `pkg-config libpng15 --cflags` \
- ${PNG2PNM_SRCS} -o png22pnm `pkg-config libpng15 --libs`
+ ${PNG2PNM_SRCS} -o png22pnm `pkg-config libpng15 --libs` -lm
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/png22pnm ${STAGEDIR}${PREFIX}/bin