summaryrefslogtreecommitdiff
path: root/graphics/zphoto/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-07-20 17:25:27 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-07-20 17:25:27 +0000
commit4a6737c40f6d927a360b2a97c3525f183e4e1232 (patch)
treeffd9cfc934bd2febc68a3d5a4f48a0c87d28e802 /graphics/zphoto/Makefile
parentUse USE_GNOMENG. (diff)
Add zphoto (zooming photo album generator)
PR: ports/40753 Submitted by: UMENO Takashi <umeno@rr.iij4u.or.jp>
Diffstat (limited to '')
-rw-r--r--graphics/zphoto/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
new file mode 100644
index 000000000000..7e868bb02b1c
--- /dev/null
+++ b/graphics/zphoto/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: zphoto
+# Date created: 19 Jul 2002
+# Whom: UMENO Takashi <umeno@rr.iij4u.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zphoto
+PORTVERSION= 0.2
+CATEGORIES= graphics www
+MASTER_SITES= http://namazu.org/~satoru/zphoto/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+
+#BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
+ Imlib2.1:${PORTSDIR}/graphics/imlib2 \
+ popt.0:${PORTSDIR}/devel/popt
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
+USE_XLIB= yes
+
+.include <bsd.port.mk>