summaryrefslogtreecommitdiff
path: root/graphics/zphoto/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-02 09:48:23 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-02 09:48:23 +0000
commit1ba909d4de0560efa4a09031cafd930e6ffa140a (patch)
tree110009f6d6ca65d2ba38847f70ab8de650b0c9a5 /graphics/zphoto/Makefile
parent- Fix d_flags on recent -CURRENT (diff)
Upgrade to 0.7.
PR: ports/63627 Submitted by: maintainer
Diffstat (limited to '')
-rw-r--r--graphics/zphoto/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index f446a00d6759..dc2d1ed01233 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,11 +20,15 @@ LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
aviplay.0:${PORTSDIR}/multimedia/avifile
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming \
+ CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}"
-USE_GMAKE= yes
+USE_GMAKE= yes
USE_XLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|<ming.h>|<ming/ming.h>|g' ${WRKSRC}/*.c ${WRKSRC}/configure
+
.include <bsd.port.mk>