summaryrefslogtreecommitdiff
path: root/graphics/xaralx-devel
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-05-16 15:00:05 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-05-16 15:00:05 +0000
commitae6d1f72c3fc2535e28e3104159642df2d134b8e (patch)
tree97e10cbb8b23a86e7f3c5483f069875f380b65f5 /graphics/xaralx-devel
parent- Add rc.d script. Thanks a lot to Christopher Sean Hilton. (diff)
Update from 0.4r991 to 0.4r1075
Diffstat (limited to 'graphics/xaralx-devel')
-rw-r--r--graphics/xaralx-devel/Makefile15
-rw-r--r--graphics/xaralx-devel/distinfo6
-rw-r--r--graphics/xaralx-devel/files/patch-Makefile.am22
3 files changed, 17 insertions, 26 deletions
diff --git a/graphics/xaralx-devel/Makefile b/graphics/xaralx-devel/Makefile
index f6e8527ee86f..d6363e991a83 100644
--- a/graphics/xaralx-devel/Makefile
+++ b/graphics/xaralx-devel/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTVERSION= 0.4r991
+PORTVERSION= 0.4r1075
PKGNAMESUFFIX= -devel
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
@@ -19,4 +19,17 @@ MD5_FILE= ${.CURDIR}/distinfo
PATCHDIR= ${.CURDIR}/files
EXTRA_PATCHES= ${MASTERDIR}/files/patch-PreComp_Makefile.am
+# we're using dlmalloc because the stock libc does not have malloc_usable_size()
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -ldlmalloc"
+
+# add wxOil with -I- appended to it before any other -I stuff, see below
+MAKE_ENV= INCLUDES="-I../wxOil -I- -I${LOCALBASE}/include/dlmalloc" \
+
+# we need to strip wxOil from the include path because it contains file
+# named strings.h which when included by /usr/include/string.h results
+# in a complete mess
+post-patch:
+ ${REINPLACE_CMD} -E -e 's|-I[^[:space:]]*/wxOil[[:space:]]||g' \
+ ${WRKSRC}/Makefile.am
+
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/xaralx-devel/distinfo b/graphics/xaralx-devel/distinfo
index 596efed57f79..493d59ac9d27 100644
--- a/graphics/xaralx-devel/distinfo
+++ b/graphics/xaralx-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (XaraLX-0.4r991.tar.gz) = 4239a4cca24d6b542000b285ff6c458f
-SHA256 (XaraLX-0.4r991.tar.gz) = 6ea18b05dca78549d339ee6499fc93ca5c66c9ba59a370a182fcab9618a9196f
-SIZE (XaraLX-0.4r991.tar.gz) = 27967947
+MD5 (XaraLX-0.4r1075.tar.gz) = 099dae67f8f9652d3e123a422f645bff
+SHA256 (XaraLX-0.4r1075.tar.gz) = 5805102bc27dc94bc3eed1bfb16a67262b1741fd31796b9e62b5125d9966d83f
+SIZE (XaraLX-0.4r1075.tar.gz) = 28002397
diff --git a/graphics/xaralx-devel/files/patch-Makefile.am b/graphics/xaralx-devel/files/patch-Makefile.am
deleted file mode 100644
index 4d8b9fa2ebe6..000000000000
--- a/graphics/xaralx-devel/files/patch-Makefile.am
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.am.orig Sun May 7 23:30:33 2006
-+++ Makefile.am Mon May 8 10:20:59 2006
-@@ -1,5 +1,10 @@
-+# we need -I- to prevent /usr/include/string.h from including our strings.h
-+# instead of /usr/include/strings.h
-+# Also we are using dlmalloc because the stock libc does not have
-+# malloc_usable_size()
- export XARAFLAGS = -I../PreComp -I../wxOil -I$(TOPDIR)/Kernel -I$(TOPDIR)/wxOil -I$(TOPDIR)/wxOil/Res \
- -I$(TOPDIR)/tools -I$(TOPDIR)/GDraw -I$(TOPDIR)/PreComp -I$(TOPDIR)/wxXtra \
-+ -I- -I$(LOCALBASE)/include/dlmalloc $(WX_CPPFLAGS) \
- -DUSE_NATIVE_XLONG -DBUILDSHADOWS -DOLD_MATRIX_TRANSFORMATIONS \
- -DVECTOR_STROKING -DEXCLUDE_FROM_XARALX -DNEW_SHADOW_RENDER -DNO_XARACMS \
- -DNEW_FEATURES -DSHOWPORTNOTE -DDO_EXPORT
-@@ -22,7 +27,7 @@
- XaraLX_SOURCES = Kernel/libKernel.a wxOil/libwxOil.a tools/libTools.a wxXtra/libwxXtra.a
- XaraLX_LDSOURCE = -Wl,--start-group $(XaraLX_SOURCES) -Wl,--end-group
- endif
--XaraLX_LDFLAGS = --debug -L$(srcdir)/$(CDRAW_LIB_DIR) $(WX_LIBS) $(LIBS) $(LIBXML2_LIBS) -lCDraw
-+XaraLX_LDFLAGS = --debug -L$(srcdir)/$(CDRAW_LIB_DIR) $(WX_LIBS) $(LIBS) $(LIBXML2_LIBS) -lCDraw -L$(LOCALBASE) -ldlmalloc
- XaraLX_LD = $(CXX)
-
- if STATIC_ENABLE