summaryrefslogtreecommitdiff
path: root/graphics/xaos/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-02-28 10:52:53 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-02-28 10:52:53 +0000
commitc16f03da811b86a1c6d1a4804b1c262eaccb2557 (patch)
tree28a64090bf9f8cd1b5dcbedc032586d48e72bab3 /graphics/xaos/Makefile
parentUpgrade to version 0.8.0. (diff)
Import of the Xaos port. Xaos is a fast fractal browser.
Closes PR #2808. Submitted by: Joseph Koshy <koshy@india.hp.com>
Diffstat (limited to 'graphics/xaos/Makefile')
-rw-r--r--graphics/xaos/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
new file mode 100644
index 000000000000..f3200076101d
--- /dev/null
+++ b/graphics/xaos/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: XaoS
+# Version required: 2.2
+# Date created: 24 February 1996
+# Whom: Joseph Koshy <koshy@india.hp.com>
+#
+# $Id$
+#
+
+DISTNAME= XaoS-2.2
+PKGNAME= xaos-2.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
+ http://www.tedium.com/XaoS/dist/ \
+ ftp://ftp.ta.jcu.cz/pub/linux/hubicka/XaoS/2.2/ \
+ http://www.paru.cas.cz/~hubicka/XaoS/dist/
+MASTER_SITE_SUBDIR= graphics
+
+MAINTAINER= ports@FreeBSD.ORG
+
+# This port will benefit from all-stops-out optimization of the code
+
+GNU_CONFIGURE= yes
+CFLAGS+= -DHAVE_SYS_PARAM_H \
+ -O6 -m486 -fstrength-reduce -ffast-math -fomit-frame-pointer\
+ -fforce-mem -fforce-addr -funroll-loops
+
+# We need to supply our own install target as the distribution doesn't
+# supply one by default
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xaos ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/xaos.6 ${PREFIX}/man/man6
+
+post-install:
+ strip ${PREFIX}/bin/xaos
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/XaoS
+ ${INSTALL_DATA} ${WRKSRC}/doc/tutorial.txt ${PREFIX}/share/doc/XaoS
+ ${INSTALL_DATA} ${WRKSRC}/doc/algorithm.txt ${PREFIX}/share/doc/XaoS
+.endif
+
+.include <bsd.port.mk>