summaryrefslogtreecommitdiff
path: root/graphics/vlc/Makefile
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2001-08-06 23:05:58 +0000
committerBrian Somers <brian@FreeBSD.org>2001-08-06 23:05:58 +0000
commit25014e3bbb2f59ef259154047dcf5c4ed74e9bda (patch)
treed7e4d1395305c6d28563977c69b77b440da7802f /graphics/vlc/Makefile
parentNot sure where I went wrong, but this is the current MD5 (diff)
Use GTK and SDL.
We now have all the niceties of subtitles and menus and that sort of stuff. Mirror the archive on ftp.awfulhak.org and people.freebsd.org Bump PORTREVISION All ideas submitted by: Scott Lambert <lambert@lambertfam.org>
Diffstat (limited to 'graphics/vlc/Makefile')
-rw-r--r--graphics/vlc/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/graphics/vlc/Makefile b/graphics/vlc/Makefile
index c35481048995..9329f8318456 100644
--- a/graphics/vlc/Makefile
+++ b/graphics/vlc/Makefile
@@ -7,14 +7,28 @@
PORTNAME= vlc
PORTVERSION= 0.2.81
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/0.2.81/
+MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/0.2.81/ \
+ ftp://ftp.Awfulhak.org/pub/vlc/ \
+ http://people.FreeBSD.org/~brian/vlc/
MAINTAINER= brian@Awfulhak.org
-GNU_CONFIGURE= yes
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= PATH_GTKCONFIG="${PREFIX}/bin/gtk12-config" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ SDL_CONFIG="${LOCALBASE}/bin/sdl11-config"
+USE_GTK= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
+pre-patch:
+ @${PERL} -pi.orig -e "s|SDL/SDL.h|SDL11/SDL.h|g" ${WRKSRC}/configure \
+ ${WRKSRC}/plugins/sdl/vout_sdl.c
+
.include <bsd.port.mk>