summaryrefslogtreecommitdiff
path: root/graphics/vlc/Makefile
diff options
context:
space:
mode:
authorBrian Somers <brian@FreeBSD.org>2001-08-12 09:44:16 +0000
committerBrian Somers <brian@FreeBSD.org>2001-08-12 09:44:16 +0000
commit0dea1d3200e232f55cabe614099af73ddd2fd9a2 (patch)
tree0bf30dc2bb7c6ec58d2f893b06db92efd0e58b9a /graphics/vlc/Makefile
parentDrop maintainership. (diff)
o Avoid modifying CFLAGS
o Create dsp.so when building with DEVFS in -current. o Pass variables to CONFIGURE_ENV in appropriate style. o Add missing libdvdcss.* to pkg-plist (bumping PORTREVISION). o post-patch hack is to select proper libs (-pthread/-lc_r). o Check XFREE86_VERSION for xvideo.so in pkg-plist. Submitted by: FUJISHIMA Satsuki <sf@FreeBSD.org>
Diffstat (limited to 'graphics/vlc/Makefile')
-rw-r--r--graphics/vlc/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/graphics/vlc/Makefile b/graphics/vlc/Makefile
index 68407b6a3842..8fc791328602 100644
--- a/graphics/vlc/Makefile
+++ b/graphics/vlc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vlc
PORTVERSION= 0.2.82
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/${PORTVERSION}/ \
ftp://ftp.Awfulhak.org/pub/vlc/ \
@@ -16,12 +17,23 @@ MAINTAINER= brian@Awfulhak.org
LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
-HAS_CONFIGURE= yes
-CONFIGURE_ENV= PATH_GTKCONFIG="${PREFIX}/bin/gtk12-config" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_GTK= yes
USE_GMAKE= yes
USE_BZIP2= yes
-.include <bsd.port.mk>
+post-patch:
+ ${PERL} -pi.orig -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+PLIST_SUB= XF4=""
+.else
+PLIST_SUB= XF4="@comment "
+.endif
+
+.include <bsd.port.post.mk>