summaryrefslogtreecommitdiff
path: root/graphics/utah-glx/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-08-25 09:27:55 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-08-25 09:27:55 +0000
commit663a202941c1540e400a49ed925579448861e329 (patch)
tree9a1a5b104b066979401682d17e019d84cabfb8fb /graphics/utah-glx/files
parentAdd svgalib - a *native* port of well-knows Linux console graphics library. (diff)
Update to the latest cvs snapshot.
- New chipset supported: S3 Savage3D (I have not tested it personally); - Improved support for already supported chipsets; - Change port versioning scheme to PORTVERSION=YYYYMMDD, because despite the promise, the project had not released its magic 1.0 version (promised to be about 3 months ago); - Catch change of the Mesa3 version.
Diffstat (limited to 'graphics/utah-glx/files')
-rw-r--r--graphics/utah-glx/files/patch-ab26
-rw-r--r--graphics/utah-glx/files/patch-ac28
-rw-r--r--graphics/utah-glx/files/patch-ad18
3 files changed, 36 insertions, 36 deletions
diff --git a/graphics/utah-glx/files/patch-ab b/graphics/utah-glx/files/patch-ab
index 053b3c568792..3a1d6d1e7cd1 100644
--- a/graphics/utah-glx/files/patch-ab
+++ b/graphics/utah-glx/files/patch-ab
@@ -1,5 +1,5 @@
---- libGLU/Makefile.in.orig Thu Dec 16 05:30:13 1999
-+++ libGLU/Makefile.in Fri Dec 31 04:19:58 1999
+--- libGLU/Makefile.in.orig Thu Aug 24 16:53:46 2000
++++ libGLU/Makefile.in Thu Aug 24 21:42:43 2000
@@ -13,10 +13,10 @@
# These define the name/version of the shared library we're building
# ------------------------------------------------------------------
@@ -16,18 +16,18 @@
# FIXME: different library version for Mesa 3.2?
@@ -104,8 +104,8 @@
- @if [ -d ${INSTALL_libdir} ]; then set +x; \
- else (set -x; ${MKDIR} ${INSTALL_libdir}); fi
- ${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLULIB} ${INSTALL_libdir}
-- ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
-- ${LN} ${GLULIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
-+# ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
-+# ${LN} ${GLULIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
- ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so ;\
- ${LN} ${GLULIB} ${INSTALL_libdir}/lib${LIBNAME}.so
+ @if [ -d ${DESTDIR}${INSTALL_libdir} ]; then set +x; \
+ else (set -x; ${MKDIR} ${DESTDIR}${INSTALL_libdir}); fi
+ ${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLULIB} ${DESTDIR}${INSTALL_libdir}
+- ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
+- ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
++# ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
++# ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
+ ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so ;\
+ ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so
else
-@@ -128,8 +128,8 @@
- ${CC} -o ./$@~ ${SHARED_LDFLAGS} -Wl,-soname,lib${LIBNAME}.so.${GLUREV_major} ${OBJS} ${MATHLIBS}
+@@ -135,8 +135,8 @@
+ fi;
${RM} $@
${MV} $@~ $@
- ${RM} lib${LIBNAME}.so.${GLUREV_major}
diff --git a/graphics/utah-glx/files/patch-ac b/graphics/utah-glx/files/patch-ac
index 167b606cea59..81348f78bf87 100644
--- a/graphics/utah-glx/files/patch-ac
+++ b/graphics/utah-glx/files/patch-ac
@@ -1,5 +1,5 @@
---- libglut/Makefile.in.orig Thu Dec 16 05:30:14 1999
-+++ libglut/Makefile.in Fri Dec 31 04:34:53 1999
+--- libglut/Makefile.in.orig Thu Aug 24 16:53:46 2000
++++ libglut/Makefile.in Thu Aug 24 21:44:21 2000
@@ -13,9 +13,9 @@
# These define the name/version of the shared library we're building
# ------------------------------------------------------------------
@@ -13,19 +13,19 @@
GLUTLIB = lib${LIBNAME}.so.${SOGLUTREV}
# Source and Object definitions
-@@ -113,8 +113,8 @@
- @if [ -d ${INSTALL_libdir} ]; then set +x; \
- else (set -x; ${MKDIR} ${INSTALL_libdir}); fi
- ${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLUTLIB} ${INSTALL_libdir}
-- ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
-- ${LN} ${GLUTLIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
-+# ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
-+# ${LN} ${GLUTLIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
- ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so ;\
- ${LN} ${GLUTLIB} ${INSTALL_libdir}/lib${LIBNAME}.so
+@@ -114,8 +114,8 @@
+ @if [ -d ${DESTDIR}${INSTALL_libdir} ]; then set +x; \
+ else (set -x; ${MKDIR} ${DESTDIR}${INSTALL_libdir}); fi
+ ${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}
+- ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
+- ${LN} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
++# ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
++# ${LN} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
+ ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so ;\
+ ${LN} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so
else
-@@ -139,8 +139,8 @@
- ${CC} -o ./$@~ ${SHARED_LDFLAGS} -Wl,-soname,lib${LIBNAME}.so.${GLUTREV_major} ${OBJS} ${MATHLIBS}
+@@ -147,8 +147,8 @@
+ fi;
${RM} $@
${MV} $@~ $@
- ${RM} lib${LIBNAME}.so.${GLUTREV_major}
diff --git a/graphics/utah-glx/files/patch-ad b/graphics/utah-glx/files/patch-ad
index ad3787fbb2e2..5e166fee090c 100644
--- a/graphics/utah-glx/files/patch-ad
+++ b/graphics/utah-glx/files/patch-ad
@@ -1,12 +1,12 @@
---- Makefile.in.orig Wed Mar 22 22:25:54 2000
-+++ Makefile.in Fri Apr 28 03:51:47 2000
-@@ -40,7 +40,8 @@
- ( cd $$i && ${MAKE} $@ ) || exit 1; \
+--- Makefile.in.orig Thu Aug 24 16:53:45 2000
++++ Makefile.in Thu Aug 24 21:46:36 2000
+@@ -44,7 +44,8 @@
done
- test -s ${sysconfdir}/glx.conf || \
-- ${INSTALL} -m 644 glx.conf ${sysconfdir}/glx.conf
-+ ${INSTALL} -c -m 644 glx.conf ${sysconfdir}/glx.conf
-+ ${INSTALL} -c -m 644 glx.conf ${sysconfdir}/glx.conf.default
+ ${MKDIR} ${DESTDIR}${sysconfdir}
+ test -s ${DESTDIR}${sysconfdir}/glx.conf || \
+- ${INSTALL} -m 644 glx.conf ${DESTDIR}${sysconfdir}/glx.conf
++ ${INSTALL} -c -m 644 glx.conf ${DESTDIR}${sysconfdir}/glx.conf
++ ${INSTALL} -c -m 644 glx.conf ${DESTDIR}${sysconfdir}/glx.conf.default
real-clean:
- ${RM} config.status
+ ${RM} config.status config.cache config.log