summaryrefslogtreecommitdiff
path: root/graphics/utah-glx/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-26 13:45:28 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-26 13:45:28 +0000
commit340b825002331dbc43e2eff62cdf2c1cd1b7f047 (patch)
treea3ba6cdec5dbc1c6c23a1ba91d8de5f6c7794c6e /graphics/utah-glx/Makefile
parentOnly tkman-2.{0,1b?} are restricted, 2.1 is under the Artistic License. (diff)
Add experimental AGP support using dfr's experimental agp driver (currently
5-current only).
Diffstat (limited to 'graphics/utah-glx/Makefile')
-rw-r--r--graphics/utah-glx/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/graphics/utah-glx/Makefile b/graphics/utah-glx/Makefile
index f6947fa2f47f..b884c144532a 100644
--- a/graphics/utah-glx/Makefile
+++ b/graphics/utah-glx/Makefile
@@ -25,6 +25,9 @@ GNU_CONFIGURE= yes
GLVER?= 14
GLUTVER?= 3
+AGP_DEVICE= /dev/agpgart
+
+CFLAGS+= -DAGP_DEVICE=\\\"${AGP_DEVICE}\\\"
CONFIGURE_SCRIPT=autogen.sh
CONFIGURE_ARGS= --enable-extra \
--with-mesa=${WRKDIRPREFIX}${.CURDIR}/../../graphics/Mesa3/work/Mesa-3.2 \
@@ -49,6 +52,10 @@ post-extract:
@${ECHO_MSG} " Users of XFree86 4.0 and above should use DRI instead."
@${ECHO_MSG}
+pre-build:
+ @find ${WRKSRC} -type f | xargs grep -l linux/agpgart | \
+ xargs perl -pi -e "s|linux/agpgart|sys/agpio|"
+
pre-install:
.if exists(${PREFIX}/lib/libGL.so.${GLVER}) && !defined(GL_CHECK_OVERRIDE)
@${ECHO_MSG}
@@ -61,6 +68,13 @@ pre-install:
.endif
post-install:
+.if exists(/usr/include/sys/agpio.h)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "The module has been built with experimental AGP support. To use it you should"
+ @${ECHO_MSG} "create device node for agp driver (mknod ${AGP_DEVICE} c 148 0) and enable"
+ @${ECHO_MSG} "AGP support in ${PREFIX}/etc/glx.conf file."
+ @${ECHO_MSG}
+.endif
${MKDIR} ${PREFIX}/share/doc/utah-glx
${INSTALL_MAN} ${WRKSRC}/docs/README.* ${PREFIX}/share/doc/utah-glx