summaryrefslogtreecommitdiff
path: root/graphics/tulip/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-08 15:09:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-08 15:09:40 +0000
commitdb2f1d53554ddedcab7477982dcb889b3a151be8 (patch)
treee57224a1bcdf5e928b190d164b9d458f561c16e5 /graphics/tulip/Makefile
parentPack correct library (diff)
add tulip 1.2.2
A system dedicated to the visualization of huge graphs
Diffstat (limited to 'graphics/tulip/Makefile')
-rw-r--r--graphics/tulip/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
new file mode 100644
index 000000000000..8de997a80f47
--- /dev/null
+++ b/graphics/tulip/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# Ports collection makefile for: tulip
+# Date created: Feb 8, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= tulip
+PORTVERSION= 1.2.2
+CATEGORIES= graphics
+MASTER_SITES= http://dept-info.labri.fr/~auber/projects/tulip/x345/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_MESA= yes
+USE_QT_VER= 3
+CFLAGS+= -DHAVE_DECL_GETOPT
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lcompat"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-lqt|-lqt-mt|" ${WRKSRC}/configure
+ @${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|malloc\.h|stdlib.h|"
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|-ldl||" -e "s|-lpthread|${PTHREAD_LIBS}|"
+
+post-configure:
+ @${FIND} ${WRKSRC} -name "Makefile" | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|-D_GETOPT_H||"
+
+pre-build:
+ @(cd ${WRKSRC} && ${GMAKE} clean)
+
+.include <bsd.port.mk>