summaryrefslogtreecommitdiff
path: root/graphics/togl/files
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-24 16:01:31 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-24 16:01:31 +0000
commit030edd1b93c9ab19cf1bce82b7a841b55ac7e868 (patch)
tree951b0003784ca3f1da1aa139f30ec9ac587d61b3 /graphics/togl/files
parentUpdate to version 1.1.5 (diff)
An OpenGL Widget for Tk
PR: 13296 Submitted by: Randall Hopper <aa8vb@ipass.net>
Diffstat (limited to 'graphics/togl/files')
-rw-r--r--graphics/togl/files/patch-aa50
-rw-r--r--graphics/togl/files/patch-ab11
2 files changed, 61 insertions, 0 deletions
diff --git a/graphics/togl/files/patch-aa b/graphics/togl/files/patch-aa
new file mode 100644
index 000000000000..bc5ff3eef199
--- /dev/null
+++ b/graphics/togl/files/patch-aa
@@ -0,0 +1,50 @@
+--- ORIG/Makefile Wed Mar 11 23:11:26 1998
++++ Makefile Wed Aug 18 18:57:46 1999
+@@ -61,23 +61,28 @@
+ CC = cc
+
+ # Compiler options:
+-COPTS = -c -O
++COPTS = -c -O -w
+
+ # Shared library linker command:
+-SHLINK = cc -G
++SHLINK = cc -shared
+
+ # Name for the shared lib:
+-#SH_LIB = libtogl.so.1.3
+-SH_LIB =
++SH_LIB = libtogl.so.1.3
++#SH_LIB =
+
+-# Where to find tcl.h, tk.h, OpenGL/Mesa headers, etc:
+-INCLUDES = -I/usr/local/include -I/usr/include/tcl
++# Where to find tc.hl, tk.h, OpenGL/Mesa headers, etc:
++INCLUDES = -I/usr/local/include/tcl8.0 \
++ -I/usr/local/include/tk8.0 \
++ -I/usr/local/include/tk8.0/generic \
++ -I/usr/X11R6/include \
++ -I/usr/include/tcl
+
+ # Where to find libtcl.a, libtk.a, OpenGL/Mesa libraries:
+-LIBDIRS = -L/usr/local/lib
++LIBDIRS = -L/usr/local/lib \
++ -L/usr/X11R6/lib
+
+ # Libraries to link with (-ldl for Linux only?):
+-LIBS = -ltk -ltcl -lGLU -lGL -L/usr/X11/lib -lX11 -lXmu -lXext -lXt -lm -ldl
++LIBS = -ltk80 -ltcl80 -lGLU -lGL -lX11 -lXmu -lXext -lXt -lm
+
+ TK_FLAGS =
+
+@@ -144,8 +149,8 @@
+ $(CC) $(CFLAGS) togl.c
+
+
+-#$(SH_LIB): togl.o
+-# $(SHLINK) $(LFLAGS) togl.o $(LIBS) -o $@
++$(SH_LIB): togl.o
++ $(SHLINK) $(LFLAGS) togl.o $(LIBS) -o $@
+
+
+
diff --git a/graphics/togl/files/patch-ab b/graphics/togl/files/patch-ab
new file mode 100644
index 000000000000..2f47b40f9ffa
--- /dev/null
+++ b/graphics/togl/files/patch-ab
@@ -0,0 +1,11 @@
+--- ORIG/togl.c Fri Aug 21 23:06:00 1998
++++ togl.c Wed Aug 18 18:41:24 1999
+@@ -118,7 +118,7 @@
+ #elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==0 && TK_RELEASE_SERIAL==2
+ # include "tkInt8.0p2.h"
+ #else
+- Sorry, you will have to edit togl.c to include the right tkInt.h file
++# include "tkInt.h"
+ #endif
+ #elif defined(WIN32)
+ #if TK_MAJOR_VERSION<8