summaryrefslogtreecommitdiff
path: root/graphics/ruby-opengl/files
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-08 03:39:09 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-08 03:39:09 +0000
commit3f75a53ded20959017d22bd6df45551855caf843 (patch)
tree2a47c58418bab4e8ebeff7128e21573f4ec461e1 /graphics/ruby-opengl/files
parentUpdate port to 4.43 (diff)
Update with bsd.ruby.mk.
Fix for Ruby 1.6. (patch-aa)
Diffstat (limited to 'graphics/ruby-opengl/files')
-rw-r--r--graphics/ruby-opengl/files/patch-aa18
1 files changed, 13 insertions, 5 deletions
diff --git a/graphics/ruby-opengl/files/patch-aa b/graphics/ruby-opengl/files/patch-aa
index e5f598e98e95..32d727eec6cf 100644
--- a/graphics/ruby-opengl/files/patch-aa
+++ b/graphics/ruby-opengl/files/patch-aa
@@ -1,5 +1,5 @@
--- extconf.rb.orig Wed Feb 16 01:31:59 2000
-+++ extconf.rb Thu Aug 24 21:18:28 2000
++++ extconf.rb Fri Sep 8 12:36:47 2000
@@ -26,8 +26,8 @@
glu_libname = "glu32"
glut_libname = "glut"
@@ -11,7 +11,7 @@
$libs = append_library($libs, "Xmu")
$libs = append_library($libs, "X11")
gl_libname = "GL"
-@@ -47,7 +47,7 @@
+@@ -47,13 +47,15 @@
}
}
File.unlink("Makefile")
@@ -20,7 +20,15 @@
ogl_flg = true
else
p "can't create OpenGL module!"
-@@ -67,7 +67,7 @@
+ exit 1
+ end
+
++$libs.sub!(/-L\. -l\$\(RUBY_INSTALL_NAME\) /, '')
++
+ $objs = ["glut.o"]
+ have_library("Xi", "XAllowDeviceEvents") &&
+ have_library("Xext", "XMITMiscGetBugMode") &&
+@@ -67,7 +69,7 @@
}
}
File.unlink("Makefile")
@@ -29,7 +37,7 @@
glut_flg = true
end
-@@ -76,11 +76,11 @@
+@@ -76,11 +78,11 @@
SHELL = /bin/sh
all: #{modules}
@@ -43,7 +51,7 @@
@echo Now Making glut extend module
@$(MAKE) -f Makefile.glut
-@@ -94,6 +94,10 @@
+@@ -94,6 +96,10 @@
install: #{modules}
#{"\t@$(MAKE) -f Makefile.ogl install" if (ogl_flg)}
#{"\t@$(MAKE) -f Makefile.glut install" if (glut_flg)}