summaryrefslogtreecommitdiff
path: root/graphics/ruby-opengl/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-08 03:39:09 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-08 03:39:09 +0000
commit3f75a53ded20959017d22bd6df45551855caf843 (patch)
tree2a47c58418bab4e8ebeff7128e21573f4ec461e1 /graphics/ruby-opengl/Makefile
parentUpdate port to 4.43 (diff)
Update with bsd.ruby.mk.
Fix for Ruby 1.6. (patch-aa)
Diffstat (limited to 'graphics/ruby-opengl/Makefile')
-rw-r--r--graphics/ruby-opengl/Makefile31
1 files changed, 11 insertions, 20 deletions
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index 5cea2e8e159e..11bb90853b7a 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -9,40 +9,31 @@ PORTNAME= opengl
PORTVERSION= 0.31
CATEGORIES= graphics ruby
MASTER_SITES= http://www2.giganet.net/~yoshi/
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= rbogl
EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
USE_MESA= yes
WRKSRC= ${WRKDIR}/oglmodule
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
-
INSTALL_TARGET= site-install
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
-
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
-
-do-configure:
- @cd ${WRKSRC}; \
- ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
-
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/opengl
- ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${PREFIX}/share/examples/ruby/opengl/
- ${MKDIR} ${PREFIX}/share/doc/ruby/opengl/ja
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/ruby/opengl/
- ${INSTALL_DATA} ${WRKSRC}/README.EUC ${PREFIX}/share/doc/ruby/opengl/ja/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/opengl
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_EXAMPLESDIR}/opengl/
+ ${MKDIR} ${RUBY_DOCDIR}/opengl/ja
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_DOCDIR}/opengl/
+ ${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_DOCDIR}/opengl/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>