summaryrefslogtreecommitdiff
path: root/graphics/optipng/Makefile
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-06-29 06:33:22 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-06-29 06:33:22 +0000
commit9fe45c1cbd6f4fb3a2d3cffd98a2c0403856e40d (patch)
treeca16370ae20465aaf78aa4411966e6ef6f9deb66 /graphics/optipng/Makefile
parentCorrectly tack manpages (diff)
- Update to 0.7.1 [1]
- Convert to optionsNG PR: ports/169063 [1] Submitted by: Fumiyuki Shimizu <fumifumi@abacustech.jp> Approved by: maintainer timeout (14 days)
Diffstat (limited to 'graphics/optipng/Makefile')
-rw-r--r--graphics/optipng/Makefile27
1 files changed, 13 insertions, 14 deletions
diff --git a/graphics/optipng/Makefile b/graphics/optipng/Makefile
index 246b88c8ecaa..fd4a8bb10f74 100644
--- a/graphics/optipng/Makefile
+++ b/graphics/optipng/Makefile
@@ -6,44 +6,43 @@
#
PORTNAME= optipng
-PORTVERSION= 0.6.5
+PORTVERSION= 0.7.1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/OptiPNG/${PORTNAME}-${PORTVERSION}
MAINTAINER= tom@hur.st
COMMENT= An optimizer for PNG files
-OPTIONS= BUNDLED_LIBPNG "Use bundled libpng" off \
- BUNDLED_ZLIB "Use bundled zlib" off
+OPTIONS_DEFINE= BUNDLED_LIBPNG BUNDLED_ZLIB
+
+BUNDLED_LIBPNG_DESC= Use bundled libpng
+BUNDLED_ZLIB_DESC= Use bundled zlib
HAS_CONFIGURE= yes
-BUILD_WRKSRC= ${WRKSRC}/src
-MAKEFILE= scripts/unix.mak
-ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/optipng
MAN1= optipng.1
-PORTDOCS= caveat.txt history.txt manual.html manual.pdf manual.txt \
- png_optimization_guide.html thanks.html todo.txt
+PORTDOCS= history.txt optipng.man.html optipng.man.pdf optipng.man.txt \
+ png_optimization.html todo.txt
.include <bsd.port.options.mk>
-.ifndef(WITH_BUNDLED_LIBPNG)
-BROKEN= does not build with libpng 1.5.x
+.if empty(PORT_OPTIONS:MBUNDLED_LIBPNG)
CONFIGURE_ARGS+= --with-system-libpng
CFLAGS+= "-I${LOCALBASE}/include"
+LDFLAGS+= "-L${LOCALBASE}/lib"
LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
.endif
-.ifndef(WITH_BUNDLED_ZLIB)
+.if empty(PORT_OPTIONS:MBUNDLED_ZLIB)
CONFIGURE_ARGS+= --with-system-zlib
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/optipng ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/man/optipng.1 ${MAN1PREFIX}/man/man1/
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/optipng/optipng ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/src/optipng/man/optipng.1 ${MAN1PREFIX}/man/man1/
post-install:
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
${INSTALL} -d ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}/
.endif