summaryrefslogtreecommitdiff
path: root/graphics/optipng/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-07-23 22:04:26 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-07-23 22:04:26 +0000
commit11bd228fd1c21cd084f2b277783b8124a6fbcc27 (patch)
tree3dfc28d7cd2ceddf7a79139dcc9c8e930b1d4f52 /graphics/optipng/Makefile
parentUpdate to 1.8.1 (diff)
New port: optipng-0.4.2
OptiPNG is a PNG optimizer that recompresses the image files to a smaller size, without losing any information. PR: 54260 Submitted by: Thomas Hurst <freaky@aagh.net> Approved by: fjoe (mentor) (implicit)
Diffstat (limited to 'graphics/optipng/Makefile')
-rw-r--r--graphics/optipng/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/optipng/Makefile b/graphics/optipng/Makefile
new file mode 100644
index 000000000000..e5e71b1a85c1
--- /dev/null
+++ b/graphics/optipng/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: optipng
+# Date created: 09 July 2003
+# Whom: Thomas Hurst <freaky@aagh.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= optipng
+PORTVERSION= 0.4.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.cs.toronto.edu/~cosmin/pngtech/optipng/
+
+MAINTAINER= freaky@aagh.net
+COMMENT= An optimizer for PNG files
+
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKEFILE= scripts/Makefile.gcc
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/optipng ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+
+.for i in CAVEAT DESIGN FEATURES HISTORY LICENSE README TODO USAGE index.html
+ ${INSTALL_MAN} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>