summaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-01-26 19:33:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-01-26 19:33:02 +0000
commita62e71dad19b700762cc1c6dbea4a06d401b68b2 (patch)
treeebd78590dc71aa33a2230b0fac23094d8ac61003 /graphics/netpbm
parent- Support CFLAGS properly (diff)
- make CC aware
- Fix build with gcc295-alpha, by forcing -O0
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 59347e0df6d8..44a21fdf1bc9 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-MAKE_ENV= LN="${LN}" RANLIB="${RANLIB}"
+MAKE_ENV= CC="${CC}" LN="${LN}" RANLIB="${RANLIB}"
MAKEFILE= GNUmakefile
INSTALL_TARGET= install.bin install.lib install.data install-dev
INSTALLS_SHLIB= yes
@@ -38,6 +38,11 @@ MAN1= netpbm.1
# -O causes an ICE in converter/other/exif.c with gcc 3.3.3 on sparc64.
CFLAGS+= -O0
.endif
+.if ${ARCH} == "alpha"
+.if ${OSVERSION} < 500000
+CFLAGS+= -O0
+.endif
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \