summaryrefslogtreecommitdiff
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-01-31 08:14:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-01-31 08:14:52 +0000
commit2704aa9a9bb043ea8782620a5dc88f30e234473e (patch)
tree95eb9a6e5d05b00d78428d843d02229e1a58fac1 /graphics/netpbm
parentWorkaround for problems installing this port on systems with emacs (diff)
- update to 10.20
- use DOCSDIR, suports now NOPORTDOCS
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile12
-rw-r--r--graphics/netpbm/distinfo3
-rw-r--r--graphics/netpbm/files/patch-converter-other-anytopnm65
-rw-r--r--graphics/netpbm/files/patch-editor-pnmquant45
-rw-r--r--graphics/netpbm/pkg-plist5
5 files changed, 12 insertions, 118 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 44a21fdf1bc9..5fff0d2f86c6 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= netpbm
-PORTVERSION= 10.19
-PORTREVISION?= 3
+PORTVERSION= 10.20
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -55,9 +54,12 @@ post-patch:
post-install:
@${ECHO_MSG} "===> Installing man pages..."
- @${REINPLACE_CMD} -e 's|doc/USERDOC|${DOCSDIR}/USERDOC|g' ${WRKSRC}/doc/netpbm.1
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/USERDOC ${DOCSDIR}
+ @${REINPLACE_CMD} -e 's|doc/USERDOC|${DOCSDIR}/USERDOC|g' \
+ ${WRKSRC}/doc/netpbm.1
${INSTALL_MAN} ${WRKSRC}/doc/netpbm.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/USERDOC ${DOCSDIR}/
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/netpbm/distinfo b/graphics/netpbm/distinfo
index ab2214d8701f..8545731d833b 100644
--- a/graphics/netpbm/distinfo
+++ b/graphics/netpbm/distinfo
@@ -1 +1,2 @@
-MD5 (netpbm-10.19.tgz) = e6bf74f0cef5271041e0ee4842c8fcef
+MD5 (netpbm-10.20.tgz) = 4aa2f767c4d58bcbdafaba6a7dd03313
+SIZE (netpbm-10.20.tgz) = 2110651
diff --git a/graphics/netpbm/files/patch-converter-other-anytopnm b/graphics/netpbm/files/patch-converter-other-anytopnm
deleted file mode 100644
index d340b0a99577..000000000000
--- a/graphics/netpbm/files/patch-converter-other-anytopnm
+++ /dev/null
@@ -1,65 +0,0 @@
---- converter/other/anytopnm Fri Sep 19 22:35:58 2003
-+++ converter/other/anytopnm Sun Dec 21 18:17:25 2003
-@@ -11,7 +11,7 @@
- # documentation. This software is provided "as is" without express or
- # implied warranty.
-
--function putInputIntoTempfile() {
-+putInputIntoTempfile() {
-
- # $1 is the input file specification
- # $2 is the temporary file name
-@@ -46,7 +46,7 @@
-
-
-
--function setMimeType() {
-+setMimeType() {
- # $1 is the file name
-
- # Christos Zoulas's current 'file' (see Freshmeat) has the --mime option.
-@@ -64,7 +64,7 @@
-
-
-
--function computeTypeFromMimeType () {
-+computeTypeFromMimeType() {
-
- # $1 is the mime type string
-
-@@ -100,7 +100,7 @@
-
-
-
--function computeTypeFromTypeDescription () {
-+computeTypeFromTypeDescription() {
-
- # $1 is the full description from 'file' of the file type
-
-@@ -196,7 +196,7 @@
-
-
-
--function computeTypeFromFilenameExtension () {
-+computeTypeFromFilenameExtension() {
- # $1 is the filename extension (".gif", etc.)
-
- case "$1" in
-@@ -304,7 +304,7 @@
-
-
-
--function determineType () {
-+determineType() {
-
- # $1 is the name of the file that contains the subject file's contents
- # $2 is the mime type or "unknown"
-@@ -327,7 +327,7 @@
-
-
-
--function convertIt () {
-+convertIt() {
- # Based on the file type computed, do the conversion
-
- # $1 is the input file name
diff --git a/graphics/netpbm/files/patch-editor-pnmquant b/graphics/netpbm/files/patch-editor-pnmquant
deleted file mode 100644
index df830ab671a1..000000000000
--- a/graphics/netpbm/files/patch-editor-pnmquant
+++ /dev/null
@@ -1,45 +0,0 @@
---- editor/pnmquant.DIST Mon Dec 29 08:11:52 2003
-+++ editor/pnmquant Mon Dec 29 08:12:24 2003
-@@ -20,7 +20,7 @@
-
- sub parseCommandLine(@) {
-
-- my @args = @_;
-+ @ARGV = @_;
-
- my ($opt_center, $opt_meancolor, $opt_meanpixel, $opt_floyd,
- $opt_spreadbrightness, $opt_spreadluminosity, $opt_mapfile);
-@@ -34,18 +34,18 @@
- "floyd|fs!" => \$opt_floyd,
- );
-
-- if (@args > 2) {
-+ if (@ARGV > 2) {
- print(STDERR "This program takes at most 2 arguments. You specified ",
-- 0+@args, "\n");
-+ 0+@ARGV, "\n");
- exit(1);
- }
-- if (@args < 1) {
-+ if (@ARGV < 1) {
- print(STDERR
- "You must specify the number of colors as an argument.\n");
- exit(1);
- }
- my $infile;
-- my $ncolors = $args[0];
-+ my $ncolors = $ARGV[0];
-
- if (!($ncolors =~ m{ ^[[:digit:]]+$ }x ) || $ncolors == 0) {
- print(STDERR
-@@ -54,8 +54,8 @@
- exit(1);
- }
-
-- if (@args > 1) {
-- $infile = $args[1];
-+ if (@ARGV > 1) {
-+ $infile = $ARGV[1];
- } else {
- $infile = "-";
- }
diff --git a/graphics/netpbm/pkg-plist b/graphics/netpbm/pkg-plist
index 4b70c739e9af..083424660fe6 100644
--- a/graphics/netpbm/pkg-plist
+++ b/graphics/netpbm/pkg-plist
@@ -50,6 +50,7 @@ bin/pamfunc
bin/pamlookup
bin/pamoil
bin/pampop9
+bin/pamscale
bin/pamseq
bin/pamslice
bin/pamstack
@@ -298,6 +299,6 @@ share/netpbm/palmgray1.map
share/netpbm/palmgray2.map
share/netpbm/palmgray4.map
share/netpbm/rgb.txt
-%%PORTDOCS%%share/doc/netpbm/USERDOC
-%%PORTDOCS%%@dirrm share/doc/netpbm
+%%PORTDOCS%%%%DOCSDIR%%/USERDOC
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/netpbm