summaryrefslogtreecommitdiff
path: root/graphics/ming/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-01-21 05:57:50 +0000
commit66acb9cd06907030a13dd56c90708c4cf4861f92 (patch)
tree1b86710ecc3bb60c1a702a6e49a3b7540d0959a4 /graphics/ming/Makefile
parentijliao@csie.nctu.edu.tw -> ijliao@FreeBSD.org (diff)
Update to Ming 0.0.9b. Now it creates Flash 4 movies.
Ports of the Perl5 module and the Ming utilities will follow soon if I can take the time.
Diffstat (limited to '')
-rw-r--r--graphics/ming/Makefile33
1 files changed, 31 insertions, 2 deletions
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index d2b8b05798e4..d8aa33d5fe00 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ming
-PORTVERSION= 0.0.3a
+PORTVERSION= 0.0.9b
CATEGORIES= graphics
MASTER_SITES= http://www.opaque.net/ming/
EXTRACT_SUFX= .tgz
@@ -18,11 +18,40 @@ MAKE_ARGS= NOPROFILE=true
DOCS= CHANGES \
CREDITS \
- Makefile \
README \
TODO
+post-extract:
+ ${MKDIR} ${WRKSRC}/c++
+ ${CP} ${WRKSRC}/../c++_ext/ming.h ${WRKSRC}/c++/
+
+post-patch:
+ ${PERL} -i -p \
+ -e 's:"\.\./\.\./c\+\+_ext/ming\.h":<c++/ming.h>:g;' \
+ -e 's:"\.\./\.\./ming\.h":<ming.h>:g;' \
+ ${WRKSRC}/../examples/c/* \
+ ${WRKSRC}/../examples/c++/* \
+ ${WRKSRC}/../examples/common/* \
+ ${WRKSRC}/c++/ming.h
+
pre-build:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ming
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${PREFIX}/share/doc/ming/
+.endfor
+ ${MKDIR} ${PREFIX}/share/examples/ming/common
+ ${INSTALL_DATA} ${WRKSRC}/../examples/common/* \
+ ${PREFIX}/share/examples/ming/common/
+ ${MKDIR} ${PREFIX}/share/examples/ming/c
+ ${INSTALL_DATA} ${WRKSRC}/../examples/c/*.c \
+ ${PREFIX}/share/examples/ming/c/
+ ${MKDIR} ${PREFIX}/share/examples/ming/c++
+ ${INSTALL_DATA} ${WRKSRC}/../examples/c++/*.cpp \
+ ${PREFIX}/share/examples/ming/c++/
+.endif
+
.include <bsd.port.mk>