summaryrefslogtreecommitdiff
path: root/graphics/mhgui/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:55:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:55:17 +0000
commit38c7ca20d1ea6f48d44b0d3e6a022b9f88efc732 (patch)
tree570e26d10036f9968aefda5e4d69e0251d9a9a7a /graphics/mhgui/Makefile
parentAnimorph is a morphing engine responsible for calculating and then (diff)
MHGUI is the GUI widget library used in the C++ version of MakeHuman.
The main idea is to have a small and easy toolkit with a set of special widgets. Some of this widgets are very special and not available in other toolkits. WWW: http://www.dedalo-3d.com/index.php PR: ports/111078 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'graphics/mhgui/Makefile')
-rw-r--r--graphics/mhgui/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/graphics/mhgui/Makefile b/graphics/mhgui/Makefile
new file mode 100644
index 000000000000..3b148891218c
--- /dev/null
+++ b/graphics/mhgui/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mhgui
+# Date created: 31 Mar 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mhgui
+PORTVERSION= 0.1
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= makehuman
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= GUI widget library for MakeHuman
+
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut \
+ animorph.0:${PORTSDIR}/graphics/animorph \
+ png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+USE_GL= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^libmhguidocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|\$$(libdir)|\$$(exec_prefix)/libdata|' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libmhguidocDATA||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>