summaryrefslogtreecommitdiff
path: root/graphics/mgp-gallery
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-04 00:02:42 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-04 00:02:42 +0000
commit1fd075e7508adcc09654d920ee5c8737ee798e5b (patch)
tree796b97ee1b07e58908c8c4bf7f57b2e53e5a55ae /graphics/mgp-gallery
parentNew Port: Stylesheets for TEI->HTML conversion (diff)
Fix .mgp files so they don't contain the Linux demo text but are suitable
for %include at top of your presentation.
Diffstat (limited to 'graphics/mgp-gallery')
-rw-r--r--graphics/mgp-gallery/Makefile5
-rw-r--r--graphics/mgp-gallery/scripts/fix-gallery11
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/mgp-gallery/Makefile b/graphics/mgp-gallery/Makefile
index 4954a9425db6..895efd9f04b7 100644
--- a/graphics/mgp-gallery/Makefile
+++ b/graphics/mgp-gallery/Makefile
@@ -9,7 +9,7 @@
PORTNAME= mgp-gallery
PORTVERSION= 2.0
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 0
CATEGORIES= graphics
MASTER_SITES= http://puchol.com/cpg/software/mgp/
@@ -40,7 +40,8 @@ do-install:
.for i in midgard backgrounds solid gradients
${MKDIR} ${PKGDATADIR}/${i}
cd ${WRKDIR}/mgp-${i}-${PORTVERSION};\
- ${INSTALL_DATA} * ${PKGDATADIR}/${i}
+ ${INSTALL_DATA} * ${PKGDATADIR}/${i};\
+ ${SCRIPTDIR}/fix-gallery "${INSTALL_DATA}" ${PKGDATADIR}/${i} *.mgp
.endfor # i in midgard backgrounds solid gradient
cd ${PREFIX};\
${RM} -f ${PLIST};\
diff --git a/graphics/mgp-gallery/scripts/fix-gallery b/graphics/mgp-gallery/scripts/fix-gallery
new file mode 100644
index 000000000000..1286c1b92855
--- /dev/null
+++ b/graphics/mgp-gallery/scripts/fix-gallery
@@ -0,0 +1,11 @@
+#!/bin/sh
+INSTALL="$1"
+TARGETDIR="$2"
+shift 2
+while test $# -gt 0; do
+ input=$1
+ shift
+ sed -e "1d" -e "/^%nodefault/q" <$input >.$input
+ $INSTALL .$input $TARGETDIR/$input
+ rm -f .$input
+done