summaryrefslogtreecommitdiff
path: root/graphics/libwpg03/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-06 19:20:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-06 19:20:24 +0000
commitc74120ccb013f6d7b98fa4e9c816f4730a83123f (patch)
tree114c9ba28e535f0ca6c5516b089c1d4d6cc7198a /graphics/libwpg03/Makefile
parentReplace @dirrm/@dirrmtry with @dir in makeplist and leftovers check (diff)
Import libwpg03
Make sure that libwpg is not conflicting with libwpg03
Diffstat (limited to 'graphics/libwpg03/Makefile')
-rw-r--r--graphics/libwpg03/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/libwpg03/Makefile b/graphics/libwpg03/Makefile
new file mode 100644
index 000000000000..a8ca343b298d
--- /dev/null
+++ b/graphics/libwpg03/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libwpg
+PORTVERSION= 0.3.0
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMESUFFIX= 03
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library and tools to work with WordPerfect Graphics (WPG) files
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+LIB_DEPENDS= librevenge-0.0.so:${PORTSDIR}/textproc/librevenge \
+ libwpd-0.10.so:${PORTSDIR}/textproc/libwpd010
+
+USES= libtool pathfix perl5 pkgconfig shebangfix tar:bzip2
+SHEBANG_FILES= ${WRKSRC}/src/conv/svg/wpg2svgbatch.pl
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --disable-werror --without-docs
+
+.include <bsd.port.mk>