summaryrefslogtreecommitdiff
path: root/graphics/librsvg2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /graphics/librsvg2
parentFollowup commit: Unbreak XFree86-4-Server-snap on -stable -- gcc 2 has no (diff)
Update to GNOME 2.4.0. For all the goodies on what's changed, known issues,
future plans, etc., please see http://www.gnome.org/start/2.4/. This commit represents work done by adamw, bland, and myself as well as many other contributers: Koop Mast <einekoai@chello.nl> Akifyev Sergey <asa@gascom.ru> Franz Klammer <klammer@webonaut.com> Øyvind Kolbu <oyvind@kebab.gaffel.nu> Thomas E. Zander <riggs@rrr.de> Jeremy Messenger <mezz7@cox.net> Without these contirbuters, and our faithful users, GNOME 2.4.0 would not be possible. Please check the FreeBSD GNOME site for any FreeBSD gotchas, as well as general FAQs and documentation (GNOME 2.4 updates to be posted soon). The best way to upgrade so that you get all shared library dependencies is: portupgrade -rf -m BATCH=yes atk portupgrade -R -m BATCH=yes gnome2 Approved by: portmgr (kris, will, myself implicitly) Requested by: re as well as many other users
Diffstat (limited to 'graphics/librsvg2')
-rw-r--r--graphics/librsvg2/Makefile12
-rw-r--r--graphics/librsvg2/distinfo2
-rw-r--r--graphics/librsvg2/files/patch-rsvg.c34
-rw-r--r--graphics/librsvg2/pkg-plist8
4 files changed, 11 insertions, 45 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index d3ba995acfbc..6e4dbb12d526 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= librsvg2
-PORTVERSION= 2.2.5
-PORTREVISION= 2
+PORTVERSION= 2.4.0
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= librsvg-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,7 +18,8 @@ COMMENT= Library for parsing and rendering SVG vector-graphic files
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- popt.0:${PORTSDIR}/devel/popt
+ popt.0:${PORTSDIR}/devel/popt \
+ gsf-1.9:${PORTSDIR}/devel/libgsf
RUN_DEPENDS= ${X11BASE}/lib/gtk-2.0/2.2.0/engines/libmetal.so:${PORTSDIR}/x11-toolkits/gtk-engines2
USE_BZIP2= yes
@@ -28,9 +28,9 @@ USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack gtk20 libartlgpl2 libxml2 libgsf
+USE_GNOME= gnomehack gtk20 libartlgpl2 libxml2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-svgz \
--disable-gtk-doc
PLIST_SUB= GTK_VERSION="2.2.0"
diff --git a/graphics/librsvg2/distinfo b/graphics/librsvg2/distinfo
index 3a3e9c8b579d..4796a4a1f2a1 100644
--- a/graphics/librsvg2/distinfo
+++ b/graphics/librsvg2/distinfo
@@ -1 +1 @@
-MD5 (gnome2/librsvg-2.2.5.tar.bz2) = db71094f14f460142b356c5ce6b9f835
+MD5 (gnome2/librsvg-2.4.0.tar.bz2) = 1a073864e5f6e9793cf23e38dc723803
diff --git a/graphics/librsvg2/files/patch-rsvg.c b/graphics/librsvg2/files/patch-rsvg.c
deleted file mode 100644
index 54b3861e208f..000000000000
--- a/graphics/librsvg2/files/patch-rsvg.c
+++ /dev/null
@@ -1,34 +0,0 @@
---- rsvg.c.orig Thu Jul 31 02:03:34 2003
-+++ rsvg.c Thu Jul 31 02:26:35 2003
-@@ -332,13 +332,14 @@
- {
- RsvgSaxHandlerGstops *z = (RsvgSaxHandlerGstops *)self;
- RsvgHandle *ctx = z->ctx;
-+ RsvgSaxHandler *prev = &z->parent->super;
-
- if (!strcmp((char *)name, z->parent_tag))
- {
- if (ctx->handler != NULL)
- {
- ctx->handler->free (ctx->handler);
-- ctx->handler = &z->parent->super;
-+ ctx->handler = prev;
- }
- }
- }
-@@ -679,13 +680,14 @@
- {
- RsvgSaxHandlerStyle *z = (RsvgSaxHandlerStyle *)self;
- RsvgHandle *ctx = z->ctx;
-+ RsvgSaxHandler *prev = &z->parent->super;
-
- if (!strcmp ((char *)name, "style"))
- {
- if (ctx->handler != NULL)
- {
- ctx->handler->free (ctx->handler);
-- ctx->handler = &z->parent->super;
-+ ctx->handler = prev;
- }
- }
- }
diff --git a/graphics/librsvg2/pkg-plist b/graphics/librsvg2/pkg-plist
index 21f66f6f4d6d..f9c5935081bb 100644
--- a/graphics/librsvg2/pkg-plist
+++ b/graphics/librsvg2/pkg-plist
@@ -6,17 +6,17 @@ lib/gtk-2.0/%%GTK_VERSION%%/engines/libsvg.so
lib/gtk-2.0/%%GTK_VERSION%%/loaders/svg_loader.so
lib/librsvg-2.a
lib/librsvg-2.so
-lib/librsvg-2.so.4
+lib/librsvg-2.so.6
libdata/pkgconfig/librsvg-2.0.pc
%%GIMP:%%libexec/gimp/1.3/plug-ins/svg
share/doc/librsvg/html/home.png
-share/doc/librsvg/html/i909.html
+share/doc/librsvg/html/i1013.html
share/doc/librsvg/html/index.html
share/doc/librsvg/html/index.sgml
share/doc/librsvg/html/left.png
share/doc/librsvg/html/r22.html
-share/doc/librsvg/html/r320.html
-share/doc/librsvg/html/r354.html
+share/doc/librsvg/html/r376.html
+share/doc/librsvg/html/r413.html
share/doc/librsvg/html/right.png
share/doc/librsvg/html/rsvg-convenience-functions.html
share/doc/librsvg/html/rsvg-core-api.html