summaryrefslogtreecommitdiff
path: root/graphics/icon-slicer/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-30 13:15:10 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-30 13:15:10 +0000
commitdaac81028d933c4acfcaf90a4c825713ad096a6d (patch)
treebedb2c73cf2a669dc93e1b3dbdcd6ed6a5a53676 /graphics/icon-slicer/Makefile
parentFix plist on FreeBSD powerpc: (diff)
Add icon-slicer.
icon-slicer is a utility for generating icon themes and libXcursor cursor themes. The inputs to icon-slicer are conceptually: A) a set of multi-layer images, one for each size B) a XML theme description file Each image contains all the cursors arranged in a grid; for cursors the layers are: - a layer with a dot for the hotspot of each cursor - the main image or first animation frame for multi-frame animated cursors - the second animation frame for multi-frame animated cursors - ... For icons, the layers are: - a layer with the images - an optional layer with attachment points for emblems - an optional layer with boxes for embedding text into icons In practice, since loading of multilayer images is not supported by standard image libraries, each layer is input as a separate image file. The theme description file contains, among other things, information about the source images to read, the location of each named cursor or icon within the grid, and a set of aliases from names to other names. WWW: http://www.freedesktop.org/wiki/Software/icon-slicer
Diffstat (limited to 'graphics/icon-slicer/Makefile')
-rw-r--r--graphics/icon-slicer/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/graphics/icon-slicer/Makefile b/graphics/icon-slicer/Makefile
new file mode 100644
index 000000000000..3d46e1e5b524
--- /dev/null
+++ b/graphics/icon-slicer/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: icon-slicer
+# Date created: 29 May 2005
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icon-slicer
+PORTVERSION= 0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.freedesktop.org/software/icon-slicer/releases/
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= An utility for generating icon and cursor themes
+
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/icon-slicer
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/ s|examples||' ${WRKSRC}/Makefile.in
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in AUTHORS README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>