summaryrefslogtreecommitdiff
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-04-30 00:45:12 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-04-30 00:45:12 +0000
commite9975e02c15096f2782b7ed7cd0d0d567bbea716 (patch)
treedeafde0e882c1e7016afca1cc2f7e1507a66db80 /graphics/gnofract4d/Makefile
parent- Update to version 3.0.9.2. (diff)
Update to 3.8
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile35
1 files changed, 23 insertions, 12 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 4ab6b5592b7f..c2649a828a66 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnofract4d
-PORTVERSION= 3.1
-PORTREVISION= 2
+PORTVERSION= 3.8
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,22 +22,34 @@ USE_GCC= 3.4+
PORTDOCS= *
INSTALLS_EGGINFO= yes
-PYDISTUTILS_EGGINFODIR= ${PREFIX}/lib/gnofract4d
+PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}
.include <bsd.port.pre.mk>
post-patch:
-# where to install libraries
- @${REINPLACE_CMD} -e 's,\(^install_lib =\).*,\1${PREFIX}/lib/${PORTNAME},' ${WRKSRC}/setup.cfg
-# contain in DATADIR ('share/foobar/gnofract4d' -> 'share/gnofract4d/foobar')
+ # where to install libraries
+ @${REINPLACE_CMD} \
+ -e 's,\(^install_lib =\).*,\1${PREFIX}/lib/${PORTNAME},' \
+ ${WRKSRC}/setup.cfg
+
+ # contain in DATADIR
+ # ('share/foobar/gnofract4d' -> # 'share/gnofract4d/foobar')
@${FIND} ${WRKSRC} -name '*.py' -exec \
- ${REINPLACE_CMD} -e "s,\([\"']\)share/\([^/]*\)/gnofract4d\1,\1${DATADIR:C/${PREFIX}\///}/\2\1," {} \;
-# libraries again
+ ${REINPLACE_CMD} \
+ -e "s,\([\"']\)share/\([^/]*\)/gnofract4d\1,\1${DATADIR:C/${PREFIX}\///}/\2\1," {} \;
+
+ # libraries again
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/gnofract4d
-# where to install docs
- @${REINPLACE_CMD} -e "s,share/doc/gnofract4d-%s/'.*,${DOCSDIR:C/${PREFIX}\///}'\,," ${WRKSRC}/setup.py
-# fixup library detection
+
+ # where to install docs
+ @${REINPLACE_CMD} \
+ -e "s,share/doc/gnofract4d-%s/'.*,${DOCSDIR:C/${PREFIX}\///}'\,," \
+ ${WRKSRC}/setup.py
+
+ # fixup library detection
@${REINPLACE_CMD} -e "s/libpng/libpng12/" ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e "s,/usr/include/jpeglib.h,${LOCALBASE}/include/jpeglib.h," ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} \
+ -e "s,/usr/include/jpeglib.h,${LOCALBASE}/include/jpeglib.h," \
+ ${WRKSRC}/setup.py
.include <bsd.port.post.mk>