summaryrefslogtreecommitdiff
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-11-17 14:55:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-11-17 14:55:41 +0000
commitc376fe707bc200f1c9e07d0cadc42ac3adcfffd0 (patch)
treeccb8dd077c519dc5aefa16223ce706b37885f35e /graphics/gnofract4d/Makefile
parentGNUstep CD player with CDDB support (diff)
- Fix png, jpeg library detection
PR: ports/105027 Submitted by: Derek Marcotte <derek.4548bfb0@razorfever.net> - Fix plist
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index bb9daa4384f1..fc11e483448e 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnofract4d
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,15 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Weird GNOME fractal generator
-USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui lthack \
pygtk2
USE_PYTHON= yes
USE_PYDISTUTILS=yes
USE_GCC= 3.4
-PLIST_FILES= bin/gnofract4d
-
PORTDOCS= *
.include <bsd.port.pre.mk>
@@ -37,13 +35,8 @@ post-patch:
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," ${WRKSRC}/gnofract4d
# where to install docs
@${REINPLACE_CMD} -e "s,share/doc/gnofract4d-%s/'.*,${DOCSDIR:C/${PREFIX}\///}'\,," ${WRKSRC}/setup.py
-
-post-install:
-.for dir in ${PREFIX}/lib/gnofract4d ${PREFIX}/share/gnofract4d ${PREFIX}/share/gnome/help/gnofract4d
- @${FIND} ${dir} ! -type d | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${dir} -type d | ${SORT} -r | \
- ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
-.endfor
+# fixup library detection
+ @${REINPLACE_CMD} -e "s/libpng/libpng12/" ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e "s,/usr/include/jpeglib.h,${LOCALBASE}/include/jpeglib.h," ${WRKSRC}/setup.py
.include <bsd.port.post.mk>