summaryrefslogtreecommitdiff
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-17 19:23:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-17 19:23:10 +0000
commitc030d56b056d934a6c8c2dc57e95b38f0feb643e (patch)
tree5120c32e7200e0042c35a374728bc29a7eab76f9 /graphics/gnofract4d/Makefile
parentupgrade to 4.2.0 (diff)
upgrade to 1.6
PR: 32855 Submitted by: Ports Fury
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 3258eaa77b58..55247c1dcd2d 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnofract4d
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,11 +19,13 @@ USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-compile-warnings=no
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "*Makefile*" | xargs ${PERL} -pi -e \
+ 's|-g -O2 -Wall -D_REENTRANT|\@CXXFLAGS\@|g ; \
+ s|\$$\(datadir\)/gnome|\$$\(datadir\)|g ; \
+ s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
.include <bsd.port.mk>