summaryrefslogtreecommitdiff
path: root/graphics/gnofract4d/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-31 21:54:35 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-31 21:54:35 +0000
commitb9cbb3542593d8f81389c26d7ea8075cd2d63d48 (patch)
tree70ab193bce70b88c3171ba12215708548a48f952 /graphics/gnofract4d/Makefile
parentUpdate to version 6.1.0. (diff)
Gnofract4D is a weird fractal-generating program
written for the GNOME project. But it makes very nice looking fractals. PR: 15797 Submitted by: Will Andrews <andrews@technologist.com>
Diffstat (limited to 'graphics/gnofract4d/Makefile')
-rw-r--r--graphics/gnofract4d/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
new file mode 100644
index 000000000000..71cbeaf838a1
--- /dev/null
+++ b/graphics/gnofract4d/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gnofract4d
+# Version required: 1.0
+# Date created: 30 Dec 1999
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= gnofract4d-1.0
+CATEGORIES= graphics
+MASTER_SITES= http://download.sourceforge.net/gnofract4d/
+
+MAINTAINER= andrews@technologist.com
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ gnomeui.3:${PORTSDIR}/x11/gnomelibs
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG}
+CONFIGURE_ARGS+=--datadir=${PREFIX}/share
+USE_NEWGCC= yes
+
+.include <bsd.port.mk>