summaryrefslogtreecommitdiff
path: root/graphics/gle/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-02 15:10:04 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-02 15:10:04 +0000
commitf56d5946acdfa6a488c90cf18e58a79a192d4297 (patch)
tree58410cb906716be3fb5ee40ad2f9132b1bb9196b /graphics/gle/Makefile
parentAdd jetty - a 100% pure Java WWW server. (diff)
Add new gle port.
GLE is a library of C functions that draw extruded surfaces, including surfaces of revolution, sweeps, tubes, polycones, polycylinders and helicoids. GLE uses the OpenGL(R) API to perform the actual rendering. PR: 20931 Submitted by: David Gilbert <dgilbert@velocet.ca>
Diffstat (limited to 'graphics/gle/Makefile')
-rw-r--r--graphics/gle/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
new file mode 100644
index 000000000000..fc3bbc0726b7
--- /dev/null
+++ b/graphics/gle/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: GLE
+# Date created: 29 August 2000
+# Whom: David Gilbert <dgilbert@velocet.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gle
+PORTVERSION= 3.0.1
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://linas.org/gle/ \
+ http://metalab.unc.edu/pub/Linux/libs/X/ \
+ ftp://tsx-11.mit.edu/pub/linux/sources/libs/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dgilbert@velocet.ca
+
+USE_X_PREFIX= yes
+USE_MESA= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= "LIBS=-L${X11BASE}/lib -lXext"
+
+MAN3= gle.3gle gleExtrusion.3gle gleHelicoid.3gle gleLathe.3gle \
+ glePolyCone.3gle glePolyCylinder.3gle gleScrew.3gle \
+ gleSetJoinStyle.3gle gleSetNumSides.3gle gleSpiral.3gle \
+ gleSuperExtrusion.3gle gleTextureMode.3gle gleToroid.3gle \
+ gleTwistExtrusion.3gle
+
+.include <bsd.port.mk>