summaryrefslogtreecommitdiff
path: root/graphics/glass
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-29 11:53:56 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-29 11:53:56 +0000
commitb2c38304d2e06ac34dd741e48469737a44f55008 (patch)
tree751e909084557a6dd14ccb7dbee4308df92e945d /graphics/glass
parent- Update to version 1.0.3 (diff)
add glass
GLASS (openGL Articulated Structure System) is a 3D library PR: 29991 Submitted by: Patrick Li <pat@databits.net>
Diffstat (limited to 'graphics/glass')
-rw-r--r--graphics/glass/Makefile37
-rw-r--r--graphics/glass/distinfo1
-rw-r--r--graphics/glass/files/patch-Makefile18
-rw-r--r--graphics/glass/pkg-comment1
-rw-r--r--graphics/glass/pkg-descr8
-rw-r--r--graphics/glass/pkg-plist7
6 files changed, 72 insertions, 0 deletions
diff --git a/graphics/glass/Makefile b/graphics/glass/Makefile
new file mode 100644
index 000000000000..992982e0698a
--- /dev/null
+++ b/graphics/glass/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: glass
+# Date created: Thu Aug 23 09:10:22 EDT 2001
+# Whom: pat@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= glass
+PORTVERSION= 1.1.1
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pat@databits.net
+
+USE_MESA= yes
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+INSTALLS_SHLIB= yes
+
+pre-patch:
+ @${PERL} -pi -e 's|malloc.h|stdlib.h|' ${WRKSRC}/*.c
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/libglass.so.1 ${PREFIX}/lib
+ @${LN} -sf ${PREFIX}/lib/libglass.so.1 ${PREFIX}/lib/libglass.so
+ @${INSTALL_DATA} ${WRKSRC}/glass.h ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/glass_types.h ${PREFIX}/include
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/../docs/*.html \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/glass/distinfo b/graphics/glass/distinfo
new file mode 100644
index 000000000000..5d3b592c5c1f
--- /dev/null
+++ b/graphics/glass/distinfo
@@ -0,0 +1 @@
+MD5 (glass-1.1.1.tar.gz) = 2bb0850bddc41ba9575dc5ef79f13d76
diff --git a/graphics/glass/files/patch-Makefile b/graphics/glass/files/patch-Makefile
new file mode 100644
index 000000000000..64332c4515bf
--- /dev/null
+++ b/graphics/glass/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Sun Aug 19 04:00:33 2001
++++ Makefile Thu Aug 23 10:06:34 2001
+@@ -1,12 +1,11 @@
+-CC = gcc
+ GLASS_VERSION = 1.1.1
+-CFLAGS = -g -O3 -Wall -DVERSION_STRING=\"$(GLASS_VERSION)\"
+-LIBS = -lGL
++CFLAGS += -Wall -I/usr/X11R6/include -DVERSION_STRING=\"$(GLASS_VERSION)\"
++LIBS = -L/usr/X11R6/lib -lGL
+ OBJS = glass_apoint.o glass_component.o glass_draw.o glass_interface.o glass_library.o \
+ glass_load.o glass_material.o glass_object.o glass_rgb.o glass_save.o \
+ glass_texture.o glass_tlist.o glass_transform.o glass_triangle.o glass_variable.o
+ all: $(OBJS)
+- $(CC) -shared -Wl,-soname,libglass.so.1 -o libglass.so.$(GLASS_VERSION) $(OBJS) -lc
++ $(CC) -shared -Wl,-soname,libglass.so.1 -o libglass.so.1 $(OBJS) $(LIBS) -lc
+
+ $(OBJS): glass_types.h glass.h
+
diff --git a/graphics/glass/pkg-comment b/graphics/glass/pkg-comment
new file mode 100644
index 000000000000..f3d906ece496
--- /dev/null
+++ b/graphics/glass/pkg-comment
@@ -0,0 +1 @@
+GLASS (openGL Articulated Structure System) is a 3D library
diff --git a/graphics/glass/pkg-descr b/graphics/glass/pkg-descr
new file mode 100644
index 000000000000..a5738ecd657c
--- /dev/null
+++ b/graphics/glass/pkg-descr
@@ -0,0 +1,8 @@
+GLASS is a 3D library, designed to make easy use of structured
+models in open GL applications. What do I mean by structured? That
+is models, that are made up of components linked by basic transforms,
+for example, rotations and translations. By using GLASS in an
+application, these models can be loaded, modified, and displayed
+using a minimum of function calls.
+
+WWW: http://glass.sourceforge.net/
diff --git a/graphics/glass/pkg-plist b/graphics/glass/pkg-plist
new file mode 100644
index 000000000000..ba2d9f8baec0
--- /dev/null
+++ b/graphics/glass/pkg-plist
@@ -0,0 +1,7 @@
+include/glass.h
+include/glass_types.h
+lib/libglass.so
+lib/libglass.so.1
+%%PORTDOCS%%share/doc/glass/specification.html
+%%PORTDOCS%%share/doc/glass/tutorial.html
+%%PORTDOCS%%@dirrm share/doc/glass