summaryrefslogtreecommitdiff
path: root/graphics/gimpshop
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-11-27 10:41:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-11-27 10:41:41 +0000
commitd829874393bc35dd9303578e4ee424358a06a725 (patch)
tree84c234e4f02c36b6c336099fdfe954e747df2ae2 /graphics/gimpshop
parentfix build with non-standard X11BASE path (diff)
- Fix startup crash with non-english locales
PR: ports/105906 Reported by: girgen Obtained from: graphics/gimp port
Diffstat (limited to 'graphics/gimpshop')
-rw-r--r--graphics/gimpshop/Makefile2
-rw-r--r--graphics/gimpshop/files/patch-plug-ins.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/graphics/gimpshop/Makefile b/graphics/gimpshop/Makefile
index 24ecd9a2d9f4..3d069d563547 100644
--- a/graphics/gimpshop/Makefile
+++ b/graphics/gimpshop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gimpshop
PORTVERSION= 2.2.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= http://www.plasticbugs.com/blogimg/ \
http://freebsd.powered.net/distfiles/
diff --git a/graphics/gimpshop/files/patch-plug-ins.c b/graphics/gimpshop/files/patch-plug-ins.c
new file mode 100644
index 000000000000..f7650f0e0529
--- /dev/null
+++ b/graphics/gimpshop/files/patch-plug-ins.c
@@ -0,0 +1,19 @@
+--- app/plug-in/plug-ins.c.orig Wed Nov 17 15:51:50 2004
++++ app/plug-in/plug-ins.c Sun Oct 22 18:58:36 2006
+@@ -317,6 +317,8 @@
+
+ if (! gimp->no_interface)
+ {
++ gimp_menus_init (gimp, gimp->plug_in_defs, STD_PLUGINS_DOMAIN);
++
+ gimp->load_procs = g_slist_sort_with_data (gimp->load_procs,
+ plug_ins_file_proc_compare,
+ gimp);
+@@ -324,7 +326,6 @@
+ plug_ins_file_proc_compare,
+ gimp);
+
+- gimp_menus_init (gimp, gimp->plug_in_defs, STD_PLUGINS_DOMAIN);
+ }
+
+ /* build list of automatically started extensions */