summaryrefslogtreecommitdiff
path: root/graphics/gd/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-12 09:34:33 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-12 09:34:33 +0000
commita128c373e685440e41cf64e176cc980c2c868ff6 (patch)
tree2b835ce35ddc3f21531e6eff03ea6dacb1b6c450 /graphics/gd/Makefile
parentadd Maaate, a MPEG audio analysis toolkit (diff)
Update to 1.8.4.
Add MASTER_SITE_RINGSERVER to MASTER_SITES. Add a couple of patches to complete GD's Japanese support. PR: ports/24930 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>, knu Approved by: billf (MAINTAINER)
Diffstat (limited to 'graphics/gd/Makefile')
-rw-r--r--graphics/gd/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 92f499cdd159..8dfda987f477 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: gd
+# New ports collection makefile for: gd
# Date created: 27 Mar 1998
# Whom: jeff@cetlink.net
#
@@ -6,17 +6,19 @@
#
PORTNAME= gd
-PORTVERSION= 1.8.3
+PORTVERSION= 1.8.4
CATEGORIES= graphics
MASTER_SITES= http://www.boutell.com/gd/http/ \
- ftp://ftp.boutell.com/pub/boutell/gd/
+ ftp://ftp.boutell.com/pub/boutell/gd/ \
+ ${MASTER_SITE_RINGSERVER}
+MASTER_SITE_SUBDIR= graphics/gd
MAINTAINER= billf@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ freetype.6:${PORTSDIR}/print/freetype2
-USE_FREETYPE= yes
.if defined(WITH_X11)
USE_XLIB= yes
USE_XPM= yes
@@ -24,13 +26,13 @@ USE_XPM= yes
INSTALLS_SHLIB= yes
-pre-fetch:
+pre-everything:
.if !defined(WITH_X11)
- @${ECHO} -n "If you want to compile in X support use "
- @${ECHO} "'make -DWITH_X11' instead"
+ @${ECHO_MSG} "If you want to compile in X support use "
+ @${ECHO_MSG} "'make -DWITH_X11' instead"
.endif
-pre-install:
- ${MKDIR} ${PREFIX}/include/gd
+post-extract:
+ @${RM} -f ${WRKSRC}/*.o
.include <bsd.port.mk>