summaryrefslogtreecommitdiff
path: root/graphics/fraqtive
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2008-04-13 13:16:18 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2008-04-13 13:16:18 +0000
commit6af982ec4b90a8fd62a0987f5fcc6f7a8634d9c1 (patch)
tree5a3fd13e104b2575de8d4957076241afac6a15dd /graphics/fraqtive
parent- Fix build with newer openssl (>= 0.9.8b) (diff)
- Update to version 0.4.0 [1]
- Add patch to fix frequent crashes on SMP machines [2] PR: ports/122084 [1] Submitted by: Max Brazhnikov <makc@issp.ac.ru> [1] Obtained from: Fraqtive SVN [2]
Diffstat (limited to 'graphics/fraqtive')
-rw-r--r--graphics/fraqtive/Makefile36
-rw-r--r--graphics/fraqtive/distinfo6
-rw-r--r--graphics/fraqtive/pkg-plist51
3 files changed, 41 insertions, 52 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
index f51322a73490..7a80c6cd1aa1 100644
--- a/graphics/fraqtive/Makefile
+++ b/graphics/fraqtive/Makefile
@@ -6,21 +6,35 @@
#
PORTNAME= fraqtive
-PORTVERSION= 0.3.1
-PORTREVISION= 2
-CATEGORIES= graphics kde
-MASTER_SITES= http://fraqtive.mimec.org/files/
+PORTVERSION= 0.4.0
+CATEGORIES= graphics
+MASTER_SITES= SF
MAINTAINER= markus@FreeBSD.org
COMMENT= Draws Mandelbrot and Julia fractals
USE_BZIP2= yes
-USE_KDELIBS_VER=3
-USE_GL= yes
-USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_QT_VER= 4
+QT_COMPONENTS= gui opengl qmake_build uic_build moc_build rcc_build
+QT_NONSTANDARD= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" \
+ QMAKE_CFLAGS="${CFLAGS}"
+CONFIGURE_ARGS= -prefix ${PREFIX} -qmake ${QMAKE}
-post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+OPTIONS= SSE2 "Enable SSE2 optimization" off
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_SSE2)
+CONFIGURE_ARGS+=-no-sse2
+.endif
+
+post-configure:
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|' \
+ -e 's|^LINK .*|LINK=${CXX}|' \
+ -e 's|^CFLAGS .*|CFLAGS=${CFLAGS} -Wall -W $$\(DEFINES\)|' \
+ -e 's|^CXXFLAGS .*|CXXFLAGS=${CXXFLAGS} -Wall -W $$\(DEFINES\)|'
+
+.include <bsd.port.post.mk>
diff --git a/graphics/fraqtive/distinfo b/graphics/fraqtive/distinfo
index ce62a18436db..f5235b8ee8e2 100644
--- a/graphics/fraqtive/distinfo
+++ b/graphics/fraqtive/distinfo
@@ -1,3 +1,3 @@
-MD5 (fraqtive-0.3.1.tar.bz2) = edc51dfcf61183df9cb3eb1b18a71137
-SHA256 (fraqtive-0.3.1.tar.bz2) = ab491fedeca621df778bad8d98dfd14cbf60833acaedf5f9f6f75fa070cd92c7
-SIZE (fraqtive-0.3.1.tar.bz2) = 507994
+MD5 (fraqtive-0.4.0.tar.bz2) = e2b66186ec7d7707aec59295d8f8c6a8
+SHA256 (fraqtive-0.4.0.tar.bz2) = 3246187d3c6ba00d4d75d6de4f8ad65e2bb04884c900cbf9d16c3962c12f19d6
+SIZE (fraqtive-0.4.0.tar.bz2) = 75011
diff --git a/graphics/fraqtive/pkg-plist b/graphics/fraqtive/pkg-plist
index ed98b3627bd0..a5cf7b0a5e13 100644
--- a/graphics/fraqtive/pkg-plist
+++ b/graphics/fraqtive/pkg-plist
@@ -1,42 +1,17 @@
bin/fraqtive
-share/applnk/Utilities/fraqtive.desktop
-share/apps/fraqtive/fraqtiveui.rc
-share/apps/fraqtive/icons/hicolor/16x16/actions/frdisplay.png
-share/apps/fraqtive/icons/hicolor/16x16/actions/frgradedit.png
-share/apps/fraqtive/icons/hicolor/16x16/actions/frgradinv.png
-share/apps/fraqtive/icons/hicolor/16x16/actions/frparams.png
-share/apps/fraqtive/icons/hicolor/16x16/actions/frtab2d.png
-share/apps/fraqtive/icons/hicolor/16x16/actions/frtab3d.png
-share/apps/fraqtive/icons/hicolor/22x22/actions/frgradedit.png
-share/apps/fraqtive/icons/hicolor/22x22/actions/frgradinv.png
-share/config/fraqtiverc
-share/doc/HTML/de/fraqtive/common
-share/doc/HTML/de/fraqtive/index.cache.bz2
-share/doc/HTML/de/fraqtive/index.docbook
-share/doc/HTML/en/fraqtive/common
-share/doc/HTML/en/fraqtive/index.cache.bz2
-share/doc/HTML/en/fraqtive/index.docbook
+share/applications/fraqtive.desktop
share/icons/hicolor/16x16/apps/fraqtive.png
+share/icons/hicolor/22x22/apps/fraqtive.png
share/icons/hicolor/32x32/apps/fraqtive.png
share/icons/hicolor/48x48/apps/fraqtive.png
-share/locale/de/LC_MESSAGES/fraqtive.mo
-share/locale/et/LC_MESSAGES/fraqtive.mo
-share/locale/fr/LC_MESSAGES/fraqtive.mo
-share/locale/it/LC_MESSAGES/fraqtive.mo
-share/locale/nl/LC_MESSAGES/fraqtive.mo
-share/locale/pl/LC_MESSAGES/fraqtive.mo
-share/locale/pt/LC_MESSAGES/fraqtive.mo
-share/locale/ru/LC_MESSAGES/fraqtive.mo
-share/locale/sr/LC_MESSAGES/fraqtive.mo
-share/locale/sv/LC_MESSAGES/fraqtive.mo
-share/locale/vi/LC_MESSAGES/fraqtive.mo
-@dirrm share/doc/HTML/en/fraqtive
-@dirrm share/doc/HTML/de/fraqtive
-@dirrmtry share/config
-@dirrm share/apps/fraqtive/icons/hicolor/22x22/actions
-@dirrm share/apps/fraqtive/icons/hicolor/22x22
-@dirrm share/apps/fraqtive/icons/hicolor/16x16/actions
-@dirrm share/apps/fraqtive/icons/hicolor/16x16
-@dirrm share/apps/fraqtive/icons/hicolor
-@dirrm share/apps/fraqtive/icons
-@dirrm share/apps/fraqtive
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications