summaryrefslogtreecommitdiff
path: root/graphics/fraqtive
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-07-27 11:03:38 +0000
commit52e8b487f6dc73b0d0baafc955c59e83ab33c41a (patch)
tree167ee4bd8c4cd737246cf4e2c40f36e42042084e /graphics/fraqtive
parent- Update to 0.10 (diff)
- Convert my ports to new options framework
- use CONFLICTS_INSTALL - other minor changes
Diffstat (limited to 'graphics/fraqtive')
-rw-r--r--graphics/fraqtive/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
index a555677bbd74..30f54a673c59 100644
--- a/graphics/fraqtive/Makefile
+++ b/graphics/fraqtive/Makefile
@@ -24,13 +24,14 @@ CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" \
CONFIGURE_ARGS= -prefix ${PREFIX} -qmake ${QMAKE}
MAKE_JOBS_SAFE= yes
-OPTIONS= SSE2 "Enable SSE2 optimization" off
+OPTIONS_DEFINE= SSE2
+SSE2_DESC= Enable SSE2 optimization
STRIP_FILES= bin/fraqtive
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_SSE2)
+.if !${PORT_OPTIONS:MSSE2}
CONFIGURE_ARGS+=-no-sse2
.endif
@@ -44,4 +45,4 @@ post-configure:
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>