summaryrefslogtreecommitdiff
path: root/graphics/evolvotron/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-17 16:03:35 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-17 16:03:35 +0000
commit2354d33181f3931bca0d769b9f102f2ac46e3c90 (patch)
tree2fe43dcd3ff921ba83dc9857ead53694a47521a3 /graphics/evolvotron/Makefile
parentUpdate to 0.2.3. (diff)
Evolvotron is interactive "generative art" software to evolve
images/textures/patterns through an iterative process of random mutation and user-selection driven evolution PR: 50232 Submitted by: David Yeske <dyeske@yahoo.com>
Diffstat (limited to 'graphics/evolvotron/Makefile')
-rw-r--r--graphics/evolvotron/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
new file mode 100644
index 000000000000..035abd098708
--- /dev/null
+++ b/graphics/evolvotron/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: evolvotron
+# Date created: 16 Mar 2003
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+
+PORTNAME= evolvotron
+PORTVERSION= 0.0.4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= dyeske@yahoo.com
+COMMENT= Generative software that evolves images/textures/patterns
+
+WRKSRC= ${WRKDIR}
+
+QTDIR?= ${X11BASE}
+USE_QT_VER= 3
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+MAKE_ENV= QTDIR="${QTDIR}"
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake \
+ -spec ${X11BASE}/share/qt/mkspecs/freebsd-g++ \
+ evolvotron.pro
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron ${PREFIX}/bin
+
+.include <bsd.port.mk>