summaryrefslogtreecommitdiff
path: root/graphics/eog2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-23 15:45:29 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-05-23 15:45:29 +0000
commita170ea92f4e316845a2a33877b33b5936fbf77f7 (patch)
tree4c7e43f2538b1aec98c8080642a3161c5381f239 /graphics/eog2/Makefile
parentadd latex2slides 0.8.1 (diff)
Add eog2 after repo copy from eog. Eog is the "Eye of GNOME" image viewer
for the GNOME 2.0 desktop.
Diffstat (limited to 'graphics/eog2/Makefile')
-rw-r--r--graphics/eog2/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/graphics/eog2/Makefile b/graphics/eog2/Makefile
index d27ca3aace24..19db167dde15 100644
--- a/graphics/eog2/Makefile
+++ b/graphics/eog2/Makefile
@@ -1,31 +1,39 @@
-# New ports collection makefile for: eog
-# Date created: 5th October 1999
-# Whom: Ade Lovett <ade@lovett.com>
+# New ports collection makefile for: eog2
+# Date created: 21 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= eog
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTNAME= eog2
+PORTVERSION= 0.117.0
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= unstable/sources/eog
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
+DISTNAME= eog-${PORTVERSION}
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gnomeprint-2.0:${PORTSDIR}/print/libgnomeprint
+
+USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>